<!DOCTYPE html><html lang="en-US" class="responsive">
      <head>
        
          <script type="text/javascript" data-platform="web" data-params='{"name":"will-and-grace/video/the-making-of-the-will-grace-reunion/4054463","type":"VIDEO"}'>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</script>
        
        <link rel="preload" as="script" href="/generetic/generated/chunks/48.532a8780e6c10b0f6228.js" />
<link rel="preload" as="style" href="/generetic/generated/generetic.4097b0874343e0416f06.css" />
<link rel="preload" as="script" href="/generetic/generated/generetic.b7b65e15a4899beea938.js" />
<link rel="preload" as="script" href="/generetic/generated/chunks/0.cd1ea8000e29d103b332.js" />
<link rel="preload" as="script" href="/generetic/generated/chunks/1.3468a70e4fa4274b234a.js" />
<link rel="preload" as="script" href="/generetic/generated/chunks/10.e9b1113811c90682e79c.js" />
<link rel="preload" as="script" href="/generetic/generated/chunks/2.276788b3b9644cb43b5f.js" />
<link rel="preload" as="script" href="/generetic/generated/chunks/43.b1ab5ba7e562738b32ed.js" />
        <link rel="stylesheet" href=/generetic/generated/generetic.4097b0874343e0416f06.css />
        <link rel="preload" as="font" href="/generetic/generated/fonts/SourceSansProRegular.woff2" type="font/woff2" crossorigin />
<link rel="preload" as="font" href="/generetic/generated/fonts/SourceSansProSemiBold.woff2" type="font/woff2" crossorigin />
<link rel="preload" as="font" href="/generetic/generated/fonts/SourceSansProLight.woff2" type="font/woff2" crossorigin />
<link rel="preload" as="font" href="/generetic/generated/fonts/MontserratRegular.woff2" type="font/woff2" crossorigin />
<link rel="preload" as="font" href="/generetic/generated/fonts/MontserratBold.woff2" type="font/woff2" crossorigin />
        <title data-reactroot="">Watch Will &amp; Grace Web Exclusive: The Making of the Will &amp; Grace Reunion - NBC.com</title><meta name="description" content="Watch Will &amp; Grace web exclusive &#x27;The Making of the Will &amp; Grace Reunion&#x27; on NBC.com" data-reactroot=""/><meta property="og:type" content="video.other" data-reactroot=""/><meta property="og:title" content="Watch Will &amp; Grace Web Exclusive: The Making of the Will &amp; Grace Reunion - NBC.com" data-reactroot=""/><meta property="og:description" content="Watch Will &amp; Grace web exclusive &#x27;The Making of the Will &amp; Grace Reunion&#x27; on NBC.com" data-reactroot=""/><meta property="og:image" content="https://img.nbc.com/sites/nbcunbc/files/images/2019/10/24/191023_4054463_The_Making_of_the_Will___Grace_Reunion_anvver_1.jpg" data-reactroot=""/><meta property="og:image:type" content="image/jpeg" data-reactroot=""/><meta property="og:image:width" content="1920" data-reactroot=""/><meta property="og:image:height" content="1080" data-reactroot=""/><meta name="twitter:title" content="Watch Will &amp; Grace Web Exclusive: The Making of the Will &amp; Grace Reunion - NBC.com" data-reactroot=""/><meta name="twitter:image" content="https://img.nbc.com/sites/nbcunbc/files/images/2019/10/24/191023_4054463_The_Making_of_the_Will___Grace_Reunion_anvver_1.jpg" data-reactroot=""/><meta name="twitter:card" content="app" data-reactroot=""/><meta name="twitter:description" content="Watch Will &amp; Grace web exclusive &#x27;The Making of the Will &amp; Grace Reunion&#x27; on NBC.com" data-reactroot=""/><meta name="twitter:app:url:iphone" content="nbctve://video/4054463" data-reactroot=""/><meta name="twitter:app:url:ipad" content="nbctve://video/4054463" data-reactroot=""/><meta name="twitter:app:url:googleplay" content="nbctve://video/4054463" data-reactroot=""/><link rel="canonical" href="https://www.nbc.com/will-and-grace/video/the-making-of-the-will-grace-reunion/4054463" data-reactroot=""/><meta property="og:video" content="https://pdk.theplatform.com/current/pdk/swf/flvPlayer.swf?id=player&amp;v=%2F%2Fplayer.theplatform.com%2Fp%2FNnzsPC%2Fwidget%2Fconfig%2Fselect%2Fmedia%2Fguid%2F2410887629%2F4054463%3Ffwsitesection%3Dnbc_video_vod_embed%26form%3Dvars%26component%3Dplayer%26autoPlay%3Dtrue%26referrer%3Dfacebook" data-reactroot=""/><meta property="og:video:secure_url" content="https://pdk.theplatform.com/current/pdk/swf/flvPlayer.swf?id=player&amp;v=%2F%2Fplayer.theplatform.com%2Fp%2FNnzsPC%2Fwidget%2Fconfig%2Fselect%2Fmedia%2Fguid%2F2410887629%2F4054463%3Ffwsitesection%3Dnbc_video_vod_embed%26form%3Dvars%26component%3Dplayer%26autoPlay%3Dtrue%26referrer%3Dfacebook" data-reactroot=""/><meta property="video:actor" content="Eric McCormack" data-reactroot=""/><meta property="video:actor" content="Debra Messing" data-reactroot=""/><meta property="video:actor" content="Sean Hayes" data-reactroot=""/><meta property="video:actor" content="Megan Mullally" data-reactroot=""/><meta property="video:duration" content="342" data-reactroot=""/><meta property="video:series" content="Will &amp; Grace" data-reactroot=""/><meta property="video:tag" content="Clip" data-reactroot=""/><meta property="video:release_date" content="2019-10-24" data-reactroot=""/><script type="application/ld+json" data-reactroot="">{"@context":"https://schema.org","@id":"4054463","@type":"TVClip","name":"The Making of the Will & Grace Reunion","description":"Take a behind-the-scenes look as the cast and crew of Will & Grace come back after ten years to delight audiences with a reunion.","video":{"@type":"VideoObject","name":"The Making of the Will & Grace Reunion","description":"Take a behind-the-scenes look as the cast and crew of Will & Grace come back after ten years to delight audiences with a reunion.","embedURL":"//player.theplatform.com/p/NnzsPC/widget/config/select/media/guid/2410887629/4054463?fwsitesection=nbc_video_vod_embed","uploadDate":"2019-10-24T16:00:00.000Z","thumbnailUrl":"https://img.nbc.com/sites/nbcunbc/files/images/2019/10/24/191023_4054463_The_Making_of_the_Will___Grace_Reunion_anvver_1.jpg","potentialAction":[{"@type":"WatchAction","target":{"@type":"EntryPoint","inLanguage":"EN","urlTemplate":"/will-and-grace/video/the-making-of-the-will-grace-reunion/4054463","actionPlatform":"http://schema.org/DesktopWebPlatform"},"expectsAcceptanceOf":[{"@type":"Offer","category":"free","eligibleRegion":[{"@type":"Country","name":"GU"},{"@type":"Country","name":"MP"},{"@type":"Country","name":"PR"},{"@type":"Country","name":"US"},{"@type":"Country","name":"VI"}]}]},{"@type":"WatchAction","target":{"@type":"EntryPoint","inLanguage":"EN","urlTemplate":"/will-and-grace/video/the-making-of-the-will-grace-reunion/4054463","actionPlatform":"http://schema.org/MobileWebPlatform"},"expectsAcceptanceOf":[{"@type":"Offer","category":"free","eligibleRegion":[{"@type":"Country","name":"GU"},{"@type":"Country","name":"MP"},{"@type":"Country","name":"PR"},{"@type":"Country","name":"US"},{"@type":"Country","name":"VI"}]}]}],"url":"/will-and-grace/video/the-making-of-the-will-grace-reunion/4054463"},"partOfSeries":{"@type":"TVSeries","name":"Will & Grace","sameAs":"http://www.imdb.com/title/tt0157246/","url":"https://www.nbc.com/will-and-grace","description":"Will & Grace - Watch episodes on NBC.com and the NBC App. Debra Messing, Eric McCormack, Sean Hayes and Megan Mullally reprise their original roles."},"partOfSeason":{"@type":"TVSeason","seasonNumber":"3"}}</script><meta charSet="utf-8" data-reactroot=""/><meta name="viewport" content="width=device-width, initial-scale=1" data-reactroot=""/><meta name="apple-media-service-subscription" content="expires=9999, type=free" data-reactroot=""/><meta property="fb:app_id" content="653521154659171" data-reactroot=""/><meta property="og:site_name" content="NBC" data-reactroot=""/><meta property="og:url" content="https://www.nbc.com/will-and-grace/video/the-making-of-the-will-grace-reunion/4054463" data-reactroot=""/><meta property="al:android:package" content="com.nbcuni.nbc" data-reactroot=""/><meta property="al:android:app_name" content="NBC" data-reactroot=""/><meta property="al:ios:app_store_id" content="442839435" data-reactroot=""/><meta property="al:ios:app_name" content="NBC" data-reactroot=""/><meta property="al:ipad:app_store_id" content="442839435" data-reactroot=""/><meta property="al:ipad:app_name" content="NBC" data-reactroot=""/><meta property="al:iphone:app_store_id" content="442839435" data-reactroot=""/><meta property="al:iphone:app_name" content="NBC" data-reactroot=""/><meta property="al:web:url" content="https://www.nbc.com/will-and-grace/video/the-making-of-the-will-grace-reunion/4054463" data-reactroot=""/><meta property="al:web:should_fallback" content="true" data-reactroot=""/><meta name="twitter:site" content="@nbc" data-reactroot=""/><meta name="twitter:site:id" content="26585095" data-reactroot=""/><meta name="twitter:url" content="https://www.nbc.com/will-and-grace/video/the-making-of-the-will-grace-reunion/4054463" data-reactroot=""/><meta name="twitter:app:country" content="US" data-reactroot=""/><meta name="twitter:app:name:iphone" content="NBC" data-reactroot=""/><meta name="twitter:app:id:iphone" content="442839435" data-reactroot=""/><meta name="twitter:app:name:ipad" content="NBC" data-reactroot=""/><meta name="twitter:app:id:ipad" content="442839435" data-reactroot=""/><meta name="twitter:app:name:googleplay" content="NBC" data-reactroot=""/><meta name="twitter:app:id:googleplay" content="com.nbcuni.nbc" data-reactroot=""/><meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" data-reactroot=""/><link rel="alternate" href="https://www.nbc.com/will-and-grace/video/the-making-of-the-will-grace-reunion/4054463" hrefLang="en" data-reactroot=""/><link rel="alternate" href="https://www.nbc.com/will-and-grace/video/the-making-of-the-will-grace-reunion/4054463?lang=es" hrefLang="es" data-reactroot=""/><link rel="shortcut icon" href="/generetic/favicon.ico" data-reactroot=""/><link rel="apple-touch-icon" href="/generetic/images/apple-touch-icon.png" data-reactroot=""/><script type="text/javascript" data-reactroot="">
      var mParticleConfig = {"apiKey":"69dedba1e9714049b35bde9e2f9bf059","delay":2000,"isDevelopmentMode":false,"planId":"nbcu_data_plan","planVersion":"15","v1SecureServiceUrl":"map.mp.nbc.com/webevents/v1/JS/","v2SecureServiceUrl":"map.mp.nbc.com/webevents/v2/JS/","v3SecureServiceUrl":"map.mp.nbc.com/webevents/v3/JS/","configUrl":"map.mp.nbc.com/tags/JS/v2/","identityUrl":"map.mp.nbc.com/identity/v1/","aliasUrl":"map.mp.nbc.com/webevents/v1/identity/","productName":"nbc.com"};
      window.mParticle = window.mParticle || {};
      window.mParticle.config = window.mParticle.config || {};
      window.mParticle.config.rq = [];
      window.mParticle.config.isDevelopmentMode = false;
      window.mParticle.config.dataPlan = {
        planId: "nbcu_data_plan",
        planVersion: 15,
      };
      window.mParticle.config.v1SecureServiceUrl = mParticleConfig.v1SecureServiceUrl;
      window.mParticle.config.v2SecureServiceUrl = mParticleConfig.v2SecureServiceUrl;
      window.mParticle.config.v3SecureServiceUrl = mParticleConfig.v3SecureServiceUrl;
      window.mParticle.config.configUrl = mParticleConfig.configUrl;
      window.mParticle.config.identityUrl = mParticleConfig.identityUrl;
      window.mParticle.config.aliasUrl = mParticleConfig.aliasUrl;
      window.mParticle.ready = function (f) {
        window.mParticle.config.rq.push(f);
      };
      window.mParticle.ready(function() {
        window.mParticle.setAppVersion('1.177.8');
      })
  </script><script type="text/javascript" src="https://map.mp.nbc.com/tags/JS/v2/69dedba1e9714049b35bde9e2f9bf059/mparticle.js" data-reactroot=""></script><script type="text/javascript" data-reactroot="">
      var s_account="nbcunetworkbu";
    </script>
        <link rel="preconnect" href="https://identity.mparticle.com">
        <link rel="preconnect" href="https://friendship.nbc.co">
        <link rel="dns-prefetch" href="https://identity.mparticle.com">
        <link rel="dns-prefetch" href="https://friendship.nbc.co">
        <link rel="dns-prefetch" href="https://static.vilynx.com">
        <link rel="dns-prefetch" href="https://public.vilynx.com">
      
  <script>!function(a){var e="https://s.go-mpulse.net/boomerang/",t="addEventListener";if("False"=="True")a.BOOMR_config=a.BOOMR_config||{},a.BOOMR_config.PageParams=a.BOOMR_config.PageParams||{},a.BOOMR_config.PageParams.pci=!0,e="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="P9G88-GQ2QU-M824B-4WKRW-LBG3T",function(){function n(e){a.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!a.BOOMR||!a.BOOMR.version&&!a.BOOMR.snippetExecuted){a.BOOMR=a.BOOMR||{},a.BOOMR.snippetExecuted=!0;var i,_,o,r=document.createElement("iframe");if(a[t])a[t]("load",n,!1);else if(a.attachEvent)a.attachEvent("onload",n);r.src="javascript:void(0)",r.title="",r.role="presentation",(r.frameElement||r).style.cssText="width:0;height:0;border:0;display:none;",o=document.getElementsByTagName("script")[0],o.parentNode.insertBefore(r,o);try{_=r.contentWindow.document}catch(O){i=document.domain,r.src="javascript:var d=document.open();d.domain='"+i+"';void(0);",_=r.contentWindow.document}_.open()._l=function(){var a=this.createElement("script");if(i)this.domain=i;a.id="boomr-if-as",a.src=e+"P9G88-GQ2QU-M824B-4WKRW-LBG3T",BOOMR_lstart=(new Date).getTime(),this.body.appendChild(a)},_.write("<bo"+'dy onload="document._l();">'),_.close()}}(),"".length>0)if(a&&"performance"in a&&a.performance&&"function"==typeof a.performance.setResourceTimingBufferSize)a.performance.setResourceTimingBufferSize();!function(){if(BOOMR=a.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var e=""=="true"?1:0,t="",n="nml5ubdilebb4x7l7ekq-f-b39665cfc-clientnsv4-s.akamaihd.net",i={"ak.v":"29","ak.cp":"260350","ak.ai":parseInt("157040",10),"ak.ol":"0","ak.cr":1,"ak.ipv":4,"ak.proto":"http/1.1","ak.rid":"21c82bc4","ak.r":34482,"ak.a2":e,"ak.m":"dscb","ak.n":"essl","ak.bpcip":"107.23.218.0","ak.cport":56654,"ak.gh":"69.192.0.60","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"reno","ak.t":"1609300245","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==kX+aijX+PErN9qeKVpapF9tU55Pt9jhHAcdam2/41CadmGu76ed7EvT3pZq5KPNFTt/j2dIMoj8doBBIFiVYoM0THkCFYbVLqan6/c5h+vJMrpVzLF/23x5Y3j8GT2hHVoMwCRLfO4C1QvohthuuRxbcEkEfaWaLUZ5BSSPiFAjlcrGZ4CRLK5DJvszxn7arMQe7Yc266MmriRdmWZrZZ34TJvSk+Kd2t9WUVk2eaQHhjH7fbFP4yJynLyRcDCLRERcsK4cvK+oGYutU+5iicov4k9I4/gCaL8nPSAUizwP/E6vIGOfylT6MZuDf53Rke3xfOK8H8XpyGRmdysLETcU2JBqU1Rt7M3IoNkCsGkaM5T2p6K/ZYkr2q8K2qSzHkY6VuyE5vMjJ3mIH7x7tmvB6AC6d0iSaY+BUUEZOW+4=","ak.pv":"435","ak.dpoabenc":""};if(""!==t)i["ak.ruds"]=t;var _={i:!1,av:function(e){var t="http.initiator";if(e&&(!e[t]||"spa_hard"===e[t]))i["ak.feo"]=void 0!==a.aFeoApplied?1:0,BOOMR.addVar(i)},rv:function(){var a=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t"];BOOMR.removeVar(a)}};BOOMR.plugins.AK={akVars:i,akDNSPreFetchDomain:n,init:function(){if(!_.i){var a=BOOMR.subscribe;a("before_beacon",_.av,null,null),a("onbeacon",_.rv,null,null),_.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head>
      <body>
        <div id="app"><div class="responsive-app" data-reactroot=""><header class="responsive-app__header" role="heading"><nav role="navigation" class="navigation navigation--show-page"><div class="navigation__inner navigation__inner--show-page"><div class="navigation__logo-wrapper navigation__logo-wrapper--show-page"><div class="navigation__item navigation__item--accessibility navigation__item--hidden"><a href="#slide-title-0" class="navigation__accessibility-button"><span>Skip to Content</span></a></div><a class="navigation__logo navigation__logo--nbc" href="/">NBC.com</a><div class="navigation__mobile--wrapper"><button type="button" class="navigation__search navigation__search--mobile" aria-label="Toggle site search"></button><button type="button" class="navigation__hamburger" aria-label="Toggle main navigation"></button></div></div><ul class="navigation__list navigation__list--nbc navigation__list--show-page" style="margin-top:0"><li class="navigation__item navigation__item--nbc-label"><span class="navigation__item__title">NBC.com</span></li><li class="navigation__item navigation__item--home"><a class="navigation__item__link" href="/"><span class="navigation__item__title">Home</span></a></li><li class="navigation__item navigation__item--shows"><a class="navigation__item__link" href="/shows/all/popular"><span class="navigation__item__title navigation__item__title--no-transform">Shows</span></a></li><li class="navigation__item navigation__item--movies"><a class="navigation__item__link" href="/movies/popular"><span class="navigation__item__title navigation__item__title--no-transform">Movies</span></a></li><li class="navigation__item"><a class="navigation__item__link" href="/networks"><span class="navigation__item__title">Networks</span></a></li><li class="navigation__item navigation__item--live"><a class="navigation__item__link" href="/live"><span class="navigation__item__title">Live</span></a></li><li class="navigation__item"><a class="navigation__item__link" href="/apps?brand=nbc"><span class="navigation__item__title">App</span></a></li><li class="navigation__item"><a class="navigation__item__link" href="https://www.nbcstore.com/?cid=nbc_global_nav_shop"><span class="navigation__item__title">Shop</span></a></li><li class="navigation__item navigation__item--search"><button type="button" class="navigation__search navigation__item__title" aria-label="Toggle site search"></button></li><li class="navigation__item navigation__item--identity"><div class="navigation__item__spinner"><div class="spinner spinner--relative spinner--small spinner--light" theme="light" style="top:19px"><span style="animation-delay:-1.2s;transform:rotate(0deg) translate(146%)"></span><span style="animation-delay:-1.1s;transform:rotate(30deg) translate(146%)"></span><span style="animation-delay:-1s;transform:rotate(60deg) translate(146%)"></span><span style="animation-delay:-0.9s;transform:rotate(90deg) translate(146%)"></span><span style="animation-delay:-0.8s;transform:rotate(120deg) translate(146%)"></span><span style="animation-delay:-0.7s;transform:rotate(150deg) translate(146%)"></span><span style="animation-delay:-0.6s;transform:rotate(180deg) translate(146%)"></span><span style="animation-delay:-0.5s;transform:rotate(210deg) translate(146%)"></span><span style="animation-delay:-0.4s;transform:rotate(240deg) translate(146%)"></span><span style="animation-delay:-0.3s;transform:rotate(270deg) translate(146%)"></span><span style="animation-delay:-0.2s;transform:rotate(300deg) translate(146%)"></span><span style="animation-delay:-0.1s;transform:rotate(330deg) translate(146%)"></span></div></div></li></ul></div></nav></header><div id="contentAccessEnabler"></div><main id="main" role="main" class="responsive-app__main"><div class="screen-reader"><p tabindex="-1" id="main-content">Main Content</p></div><div class="responsive-app__wrapper responsive-app__wrapper--nbc"><div class="video-page"><div class="video-page__sections"><div class="sticky-outer-wrapper show-header"><div class="sticky-inner-wrapper" style="position:relative;top:0px"><div class="show-header__background" style="background-image:linear-gradient(95deg, #a55f80, #0f133c)"><div class="show-header__info"><div class="show-header__title"><span class="show-header__title__inner">Will &amp; Grace</span></div><div class="show-header__tune-in">WATCH HIGHLIGHTS</div></div><div class="show-header__toggle-favorite"><a class="navigation__item__link navigation__item__link--favorite-add" aria-label="Add To Favorites" data-tip="Added to Favorites" style="color:#a55f80" role="tab" tabindex="0"><i class="show-header__add-favorite-icon"></i></a></div></div><div class="show-header__menu"><ul class="show-header__list"><li class="navigation__item__desktop-only"><a class="navigation__item__link navigation__item__link--favorite-add" aria-label="Add To Favorites" data-tip="Added to Favorites" style="color:#a55f80" role="tab" tabindex="0"><i class="show-header__add-favorite-icon"></i></a></li><li class="navigation__item__link navigation__item__link--div" style="color:#a55f80"><a class="navigation__item__link navigation__item__link_target" href="/will-and-grace" target="" aria-label="Main" role="tab" tabindex="0">main</a></li><li class="navigation__item__link navigation__item__link--div" style="color:#a55f80"><a class="navigation__item__link navigation__item__link_target" href="/will-and-grace/episodes" target="" aria-label="EPISODES" role="tab" tabindex="0">episodes</a></li><li class="navigation__item__link navigation__item__link--div" style="color:#a55f80"><a class="navigation__item__link navigation__item__link_target" href="/will-and-grace/photos" target="" aria-label="PHOTOS" role="tab" tabindex="0">photos</a></li><li class="navigation__item__link navigation__item__link--div" style="color:#a55f80"><a class="navigation__item__link navigation__item__link_target" href="/will-and-grace/credits/cast" target="" aria-label="CAST" role="tab" tabindex="0">cast</a></li><li class="navigation__item__link navigation__item__link--div" style="color:#a55f80"><a target="_blank" rel="noreferrer noopener" class="navigation__item__link navigation__item__link_target" href="https://goo.gl/vf4RcQ" aria-label="STORE" role="tab" tabindex="0">store</a></li><li class="navigation__item__link navigation__item__link--div" style="color:#a55f80"><a class="navigation__item__link navigation__item__link_target" href="/will-and-grace-original/episodes" target="" aria-label="Will &amp; Grace (Original) Episodes " role="tab" tabindex="0">will &amp; grace (original) episodes </a></li><li class="navigation__item__link navigation__item__link--div" style="color:#a55f80"><a class="navigation__item__link navigation__item__link_target" href="/global/exclusives/comedy-starts-here" target="" aria-label="MORE COMEDIES" role="tab" tabindex="0">more comedies</a></li></ul></div><div class="__react_component_tooltip place-right type-dark" data-id="tooltip"></div></div></div><section class="video-page__player video-page__player--isZoomable"><div class="video-page__player--inner"><div class="video-page__spinner"><div class="video-page__spinner__wrapper"><div class="spinner spinner--relative spinner--light" theme="light" style="top:50%"><span style="animation-delay:-1.2s;transform:rotate(0deg) translate(146%)"></span><span style="animation-delay:-1.1s;transform:rotate(30deg) translate(146%)"></span><span style="animation-delay:-1s;transform:rotate(60deg) translate(146%)"></span><span style="animation-delay:-0.9s;transform:rotate(90deg) translate(146%)"></span><span style="animation-delay:-0.8s;transform:rotate(120deg) translate(146%)"></span><span style="animation-delay:-0.7s;transform:rotate(150deg) translate(146%)"></span><span style="animation-delay:-0.6s;transform:rotate(180deg) translate(146%)"></span><span style="animation-delay:-0.5s;transform:rotate(210deg) translate(146%)"></span><span style="animation-delay:-0.4s;transform:rotate(240deg) translate(146%)"></span><span style="animation-delay:-0.3s;transform:rotate(270deg) translate(146%)"></span><span style="animation-delay:-0.2s;transform:rotate(300deg) translate(146%)"></span><span style="animation-delay:-0.1s;transform:rotate(330deg) translate(146%)"></span></div></div></div></div></section><div class="video-meta"><div class="video-meta__container"><div class="video-meta__inner"><h1 class="video-meta__title"><span>The Making of the Will &amp; Grace Reunion</span></h1><div class="video-meta__secondary-title"><span class="video-meta__badge">CLIP</span><span>10/24/19</span></div><div class="video-meta__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div><a class="video-meta__expand" style="background-color:#a55f80"><span class="video-meta__expand__text">Details</span></a></div></div></div><div class="video-meta__expandable"><div class="video-meta__details-container"><div class="video-meta__details"><a class="video-meta__app-link" href="/apps"><span class="video-meta__app-link__text">Also available on the <!-- -->nbc<!-- --> app</span></a><p class="video-meta__description">Take a behind-the-scenes look as the cast and crew of Will &amp; Grace come back after ten years to delight audiences with a reunion.</p><div class="video-meta__appearing"><span class="video-meta__appearing-title">Appearing:</span><span class="video-meta__appearing-credit">Eric McCormack</span><span class="video-meta__appearing-credit">Debra Messing</span><span class="video-meta__appearing-credit">Sean Hayes</span><span class="video-meta__appearing-credit">Megan Mullally</span></div><div class="video-meta__tags">Tags: will and grace, nbc will and grace, Debra Messing, grace, Eric McCormack, will, Sean Hayes, Jack, Megan Mullally, Karen, farewell season, final season, grace is pregnant, will and grace pregnant, season premiere, series finale, will and grace reunion</div><div class="video-meta__info"><span class="video-meta__episode">S3 E1</span><span class="video-meta__length">6 min</span><span class="video-meta__type">Web Exclusive</span><span class="video-meta__show-type">Comedy</span><span class="video-meta__show-air-type">Primetime</span></div><div class="video-meta__copyright"></div><div class="share"><a class="share__btn share__btn--facebook" aria-label="Share on Facebook" rel="noreferrer noopener" target="_blank" title="Facebook" href="https://www.facebook.com/sharer/sharer.php?u="></a><a class="share__btn share__btn--twitter" aria-label="Share on Twitter" rel="noreferrer noopener" target="_blank" title="Twitter" href="https://twitter.com/intent/tweet?text=Watch%2010%2F24%2F19%20from%20Will%20%26%20Grace%20on%20NBC.com&amp;url="></a></div></div></div></div><section class="links-selectable-group"><div class="links-selectable-group__container"><div class="links-selectable-group__inner"><div class="filter-select"><div class="filter-select__inner"><button class="filter-select__selected" type="button" aria-haspopup="true" aria-label="Most Recent">Most Recent</button><ul class="filter-select__dropdown" role="listbox" tabindex="-1"><li class="filter-select__item" role="option" aria-selected="false"><span class="filter-select__link">Most Recent</span></li><li class="filter-select__item" role="option" aria-selected="false"><span class="filter-select__link">Current Preview</span></li><li class="filter-select__item" role="option" aria-selected="false"><span class="filter-select__link">Highlight</span></li><li class="filter-select__item" role="option" aria-selected="false"><span class="filter-select__link">Sneak Peek</span></li><li class="filter-select__item" role="option" aria-selected="false"><span class="filter-select__link">Web Exclusive</span></li></ul></div></div><section class="shelf shelf--default shelf--ClipTile"><div class="section-heading section-heading--text"><h2 class="section-heading__title">Clips</h2></div><div class="shelf__inner"><button type="button" class="shelf__arrow shelf__arrow--left" disabled=""></button><div class="shelf__tiles"><div class="shelf__tiles__inner" style="transform:translate3d(0px, 0, 0)"><a class="tile tile--clip tile--zoomable" data-index="0" aria-label="Will &amp; Grace, The Best of Will Truman - Will &amp; Grace, Clip, Aired on 09/17/20" href="/will-and-grace/video/the-best-of-will-truman-will-grace/4233246"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4233246"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">The Best of Will Truman - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>09/17/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="1" aria-label="Will &amp; Grace, Jack and Karen: BFF Goals - Will &amp; Grace, Clip, Aired on 08/27/20" href="/will-and-grace/video/jack-and-karen-bff-goals-will-grace/4222006"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4222006"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Jack and Karen: BFF Goals - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>08/27/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="2" aria-label="Will &amp; Grace, Karen Gets Revenge on Everyone - Will &amp; Grace, Clip, Aired on 07/11/20" href="/will-and-grace/video/karen-gets-revenge-on-everyone-will-grace/4197688"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4197688"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Karen Gets Revenge on Everyone - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>07/11/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="3" aria-label="Will &amp; Grace, Jack Tries to Seduce Bill (Neil Patrick Harris) - Will &amp; Grace, Clip, Aired on 07/09/20" href="/will-and-grace/video/jack-tries-to-seduce-bill-neil-patrick-harris-will-grace/4196268"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4196268"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Jack Tries to Seduce Bill (Neil Patrick Harris) - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>07/09/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="4" aria-label="Will &amp; Grace, Jack and Grace Bond Over Ice Skating - Will &amp; Grace, Clip, Aired on 07/07/20" href="/will-and-grace/video/jack-and-grace-bond-over-ice-skating-will-grace/4195108"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4195108"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Jack and Grace Bond Over Ice Skating - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>07/07/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="5" aria-label="Will &amp; Grace, Will and Grace&#x27;s Photo Shoot Disaster - Will &amp; Grace, Clip, Aired on 07/02/20" href="/will-and-grace/video/will-and-graces-photo-shoot-disaster-will-grace/4193142"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4193142"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Will and Grace&#x27;s Photo Shoot Disaster - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>07/02/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="6" aria-label="Will &amp; Grace, Nadine Hates Will - Will &amp; Grace, Clip, Aired on 06/30/20" href="/will-and-grace/video/nadine-hates-will-will-grace/4191810"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4191810"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Nadine Hates Will - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>06/30/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="7" aria-label="Will &amp; Grace, Grace&#x27;s Free Therapy Hack Backfires - Will &amp; Grace, Clip, Aired on 06/27/20" href="/will-and-grace/video/graces-free-therapy-hack-backfires-will-grace/4190698"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4190698"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Grace&#x27;s Free Therapy Hack Backfires - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>06/27/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="8" aria-label="Will &amp; Grace, Grace&#x27;s Awkward Dinner Party with Diane - Will &amp; Grace, Clip, Aired on 06/25/20" href="/will-and-grace/video/graces-awkward-dinner-party-with-diane-will-grace/4189444"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4189444"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Grace&#x27;s Awkward Dinner Party with Diane - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>06/25/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="9" aria-label="Will &amp; Grace, Will and Jack Kiss on the TODAY Show - Will &amp; Grace, Clip, Aired on 06/23/20" href="/will-and-grace/video/will-and-jack-kiss-on-the-today-show-will-grace/4188162"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4188162"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Will and Jack Kiss on the TODAY Show - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>06/23/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="10" aria-label="Will &amp; Grace, Poker Night with Grace&#x27;s Mom - Will &amp; Grace, Clip, Aired on 06/20/20" href="/will-and-grace/video/poker-night-with-graces-mom-will-grace/4187158"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4187158"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Poker Night with Grace&#x27;s Mom - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>06/20/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="11" aria-label="Will &amp; Grace, Jack Performs &quot;Just Jack&quot; - Will &amp; Grace, Clip, Aired on 06/18/20" href="/will-and-grace/video/jack-performs-just-jack-will-grace/4185236"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4185236"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Jack Performs &quot;Just Jack&quot; - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>06/18/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="12" aria-label="Will &amp; Grace, Will Seduces Monet (Chloë Sevigny) - Will &amp; Grace, Clip, Aired on 06/02/20" href="/will-and-grace/video/will-seduces-monet-chloe-sevigny-will-grace/4177649"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4177649"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Will Seduces Monet (Chloë Sevigny) - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>06/02/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="13" aria-label="Will &amp; Grace, Grace&#x27;s New Intern Wants to Be Karen - Will &amp; Grace, Clip, Aired on 05/30/20" href="/will-and-grace/video/graces-new-intern-wants-to-be-karen-will-grace/4176636"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4176636"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Grace&#x27;s New Intern Wants to Be Karen - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/30/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="14" aria-label="Will &amp; Grace, Madonna as Karen&#x27;s Roommate, Liz - Will &amp; Grace, Clip, Aired on 05/28/20" href="/will-and-grace/video/madonna-as-karens-roommate-liz-will-grace/4175308"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4175308"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Madonna as Karen&#x27;s Roommate, Liz - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/28/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="15" aria-label="Will &amp; Grace, Karen Walker as Anastasia Beaverhausen - Will &amp; Grace, Clip, Aired on 05/26/20" href="/will-and-grace/video/karen-walker-as-anastasia-beaverhausen-will-grace/4173278"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4173278"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Karen Walker as Anastasia Beaverhausen - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/26/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="16" aria-label="Will &amp; Grace, Karen Finds Something Awful Among Her Jewels - Will &amp; Grace, Clip, Aired on 05/23/20" href="/will-and-grace/video/karen-finds-something-awful-among-her-jewels-will-grace/4173184"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4173184"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Karen Finds Something Awful Among Her Jewels - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/23/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="17" aria-label="Will &amp; Grace, Amber-Louise (Britney Spears) Is Hard-Core - Will &amp; Grace, Clip, Aired on 05/21/20" href="/will-and-grace/video/amberlouise-britney-spears-is-hardcore-will-grace/4171856"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4171856"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Amber-Louise (Britney Spears) Is Hard-Core - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/21/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="18" aria-label="Will &amp; Grace, What Will Stanley Leave Karen in His Will? - Will &amp; Grace, Clip, Aired on 05/19/20" href="/will-and-grace/video/what-will-stanley-leave-karen-in-his-will-will-grace/4170422"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4170422"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">What Will Stanley Leave Karen in His Will? - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/19/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="19" aria-label="Will &amp; Grace, Jack Freaks Out Over Grace&#x27;s Misfortune - Will &amp; Grace, Clip, Aired on 05/16/20" href="/will-and-grace/video/jack-freaks-out-over-graces-misfortune-will-grace/4169449"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4169449"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Jack Freaks Out Over Grace&#x27;s Misfortune - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/16/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="20" aria-label="Will &amp; Grace, Will Meets James (Taye Diggs) Dressed as Captain von Trapp - Will &amp; Grace, Clip, Aired on 05/14/20" href="/will-and-grace/video/will-meets-james-taye-diggs-dressed-as-captain-von-trapp-will-grace/4167813"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4167813"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Will Meets James (Taye Diggs) Dressed as Captain von Trapp - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/14/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="21" aria-label="Will &amp; Grace, Will and Grace Lose Their &quot;Homojo&quot; - Will &amp; Grace, Clip, Aired on 05/12/20" href="/will-and-grace/video/will-and-grace-lose-their-homojo-will-grace/4166795"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4166795"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Will and Grace Lose Their &quot;Homojo&quot; - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/12/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="22" aria-label="Will &amp; Grace, Will and Karen Have Sex with the Same Man - Will &amp; Grace, Clip, Aired on 05/09/20" href="/will-and-grace/video/will-and-karen-have-sex-with-the-same-man-will-grace/4165669"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4165669"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Will and Karen Have Sex with the Same Man - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/09/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="23" aria-label="Will &amp; Grace, Ellen DeGeneres as Sister Louise - Will &amp; Grace, Clip, Aired on 05/07/20" href="/will-and-grace/video/ellen-degeneres-as-sister-louise-will-grace/4164292"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4164292"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Ellen DeGeneres as Sister Louise - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/07/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="24" aria-label="Will &amp; Grace, Jack and Grace Confront Vince (Bobby Cannavale) - Will &amp; Grace, Clip, Aired on 05/05/20" href="/will-and-grace/video/jack-and-grace-confront-vince-bobby-cannavale-will-grace/4162674"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4162674"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Jack and Grace Confront Vince (Bobby Cannavale) - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/05/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="25" aria-label="Will &amp; Grace, Grace Seduces Matt Damon - Will &amp; Grace, Clip, Aired on 05/04/20" href="/will-and-grace/video/grace-seduces-matt-damon-will-grace/4161856"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4161856"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Grace Seduces Matt Damon - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/04/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="26" aria-label="Will &amp; Grace, Grace Finds Karen&#x27;s Fetish Film - Will &amp; Grace, Clip, Aired on 04/28/20" href="/will-and-grace/video/grace-finds-karens-fetish-film-will-grace/4158977"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4158977"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Grace Finds Karen&#x27;s Fetish Film - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/28/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="27" aria-label="Will &amp; Grace, Will, Grace, Jack and Karen Say Goodbye - Will &amp; Grace, Clip, Aired on 04/28/20" href="/will-and-grace/video/will-grace-jack-and-karen-say-goodbye-will-grace/4156590"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4156590"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Will, Grace, Jack and Karen Say Goodbye - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/28/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="28" aria-label="Will &amp; Grace, What Will &amp; Grace Means to Me - Will &amp; Grace, Clip, Aired on 04/28/20" href="/will-and-grace/video/what-will-grace-means-to-me-will-grace/4158394"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4158394"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">What Will &amp; Grace Means to Me - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/28/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="29" aria-label="Will &amp; Grace, 318 Bloopers, We Were Trying to Act! - Will &amp; Grace, Clip, Aired on 04/27/20" href="/will-and-grace/video/318-bloopers-we-were-trying-to-act-will-grace/4157394"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4157394"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">318 Bloopers, We Were Trying to Act! - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/27/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="30" aria-label="Will &amp; Grace, The Final Shoot Week Diaries - Will &amp; Grace, Clip, Aired on 04/24/20" href="/will-and-grace/video/the-final-shoot-week-diaries-will-grace/4156639"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4156639"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">The Final Shoot Week Diaries - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/24/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="31" aria-label="Will &amp; Grace, The Final Table Read - Will &amp; Grace, Clip, Aired on 04/23/20" href="/will-and-grace/video/the-final-table-read-will-grace/4156634"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4156634"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">The Final Table Read - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/23/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="32" aria-label="Will &amp; Grace, Karen and Stanley Back Together? - Will &amp; Grace, Clip, Aired on 04/23/20" href="/will-and-grace/video/karen-and-stanley-back-together-will-grace/4156586"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4156586"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Karen and Stanley Back Together? - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/23/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="33" aria-label="Will &amp; Grace, Will and Grace Make a Big Decision - Will &amp; Grace, Clip, Aired on 04/21/20" href="/will-and-grace/video/will-and-grace-make-a-big-decision-will-grace/4152350"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4152350"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Will and Grace Make a Big Decision - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/21/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="34" aria-label="Will &amp; Grace, 317 Bloopers, What If They Never Come? - Will &amp; Grace, Clip, Aired on 04/20/20" href="/will-and-grace/video/317-bloopers-what-if-they-never-come-will-grace/4151574"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4151574"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">317 Bloopers, What If They Never Come? - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/20/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="35" aria-label="Will &amp; Grace, Will &amp; Grace Season 3 Finale: First Look, Clip, Aired on 04/17/20" href="/will-and-grace/video/will-grace-season-3-finale-first-look/4152304"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4152304"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Will &amp; Grace Season 3 Finale: First Look</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/17/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="36" aria-label="Will &amp; Grace, Jack Is Finally Famous - Will &amp; Grace, Clip, Aired on 04/16/20" href="/will-and-grace/video/jack-is-finally-famous-will-grace/4152346"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4152346"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Jack Is Finally Famous - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/16/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="37" aria-label="Will &amp; Grace, Karen Reenacts I Love Lucy&#x27;s Grape Stomping Scene - Will &amp; Grace, Clip, Aired on 04/14/20" href="/will-and-grace/video/karen-reenacts-i-love-lucys-grape-stomping-scene-will-grace/4148155"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4148155"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Karen Reenacts I Love Lucy&#x27;s Grape Stomping Scene - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/14/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="38" aria-label="Will &amp; Grace, 316 Bloopers, That&#x27;s All You&#x27;re Giving Me? - Will &amp; Grace, Clip, Aired on 04/13/20" href="/will-and-grace/video/316-bloopers-thats-all-youre-giving-me-will-grace/4140393"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4140393"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">316 Bloopers, That&#x27;s All You&#x27;re Giving Me? - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/13/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="39" aria-label="Will &amp; Grace, Jack and Grace Reenact I Love Lucy&#x27;s Chocolate Factory Scene - Will &amp; Grace, Clip, Aired on 04/12/20" href="/will-and-grace/video/jack-and-grace-reenact-i-love-lucys-chocolate-factory-scene-will-grace/4148947"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4148947"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Jack and Grace Reenact I Love Lucy&#x27;s Chocolate Factory Scene - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/12/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="40" aria-label="Will &amp; Grace, Grace Reenacts I Love Lucy&#x27;s Vitameatavegamin Commercial - Will &amp; Grace, Clip, Aired on 04/09/20" href="/will-and-grace/video/grace-reenacts-i-love-lucys-vitameatavegamin-commercial-will-grace/4148150"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4148150"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Grace Reenacts I Love Lucy&#x27;s Vitameatavegamin Commercial - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/09/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="41" aria-label="Will &amp; Grace, Grace Tries to Get Her Baby&#x27;s Gender Results - Will &amp; Grace, Clip, Aired on 03/24/20" href="/will-and-grace/video/grace-tries-to-get-her-babys-gender-results-will-grace/4135399"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4135399"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Grace Tries to Get Her Baby&#x27;s Gender Results - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>03/24/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="42" aria-label="Will &amp; Grace, 315 Bloopers, Sean Will Walk Out! - Will &amp; Grace, Clip, Aired on 03/23/20" href="/will-and-grace/video/315-bloopers-sean-will-walk-out-will-grace/4135898"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4135898"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">315 Bloopers, Sean Will Walk Out! - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>03/23/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="43" aria-label="Will &amp; Grace, Jack Meets Cher - Will &amp; Grace, Clip, Aired on 03/21/20" href="/will-and-grace/video/jack-meets-cher-will-grace/4135880"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4135880"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Jack Meets Cher - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>03/21/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="44" aria-label="Will &amp; Grace, Will and Grace&#x27;s Gender Reveal Party - Will &amp; Grace, Clip, Aired on 03/19/20" href="/will-and-grace/video/will-and-graces-gender-reveal-party-will-grace/4135394"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4135394"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Will and Grace&#x27;s Gender Reveal Party - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>03/19/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="45" aria-label="Will &amp; Grace, Are Will and Grace That Old? - Will &amp; Grace, Clip, Aired on 03/17/20" href="/will-and-grace/video/are-will-and-grace-that-old-will-grace/4131644"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4131644"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Are Will and Grace That Old? - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>03/17/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="46" aria-label="Will &amp; Grace, 314 Bloopers, Don&#x27;t Take My Joke! - Will &amp; Grace, Clip, Aired on 03/16/20" href="/will-and-grace/video/314-bloopers-dont-take-my-joke-will-grace/4132461"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4132461"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">314 Bloopers, Don&#x27;t Take My Joke! - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>03/16/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="47" aria-label="Will &amp; Grace, Karen and Jack Drug Val - Will &amp; Grace, Clip, Aired on 03/12/20" href="/will-and-grace/video/karen-and-jack-drug-val-will-grace/4131642"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4131642"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Karen and Jack Drug Val - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>03/12/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="48" aria-label="Will &amp; Grace, Karen&#x27;s Boyfriend Bails on Her - Will &amp; Grace, Clip, Aired on 03/10/20" href="/will-and-grace/video/karens-boyfriend-bails-on-her-will-grace/4127640"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4127640"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Karen&#x27;s Boyfriend Bails on Her - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>03/10/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="49" aria-label="Will &amp; Grace, 313 Bloopers, Acting Is Hard! - Will &amp; Grace, Clip, Aired on 03/09/20" href="/will-and-grace/video/313-bloopers-acting-is-hard-will-grace/4128498"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4128498"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">313 Bloopers, Acting Is Hard! - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>03/09/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="50" aria-label="Will &amp; Grace, Jack Studies for the Gay Spelling Bee - Will &amp; Grace, Clip, Aired on 03/07/20" href="/will-and-grace/video/jack-studies-for-the-gay-spelling-bee-will-grace/4128489"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4128489"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Jack Studies for the Gay Spelling Bee - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>03/07/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="51" aria-label="Will &amp; Grace, Jack Is Disappointed in His Bar Opening - Will &amp; Grace, Clip, Aired on 03/05/20" href="/will-and-grace/video/jack-is-disappointed-in-his-bar-opening-will-grace/4127635"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4127635"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Jack Is Disappointed in His Bar Opening - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>03/05/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="52" aria-label="Will &amp; Grace, Is Karen&#x27;s New Boyfriend a &quot;Dirty John?&quot; - Will &amp; Grace, Clip, Aired on 03/03/20" href="/will-and-grace/video/is-karens-new-boyfriend-a-dirty-john-will-grace/4123809"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4123809"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Is Karen&#x27;s New Boyfriend a &quot;Dirty John?&quot; - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>03/03/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="53" aria-label="Will &amp; Grace, 312 Bloopers, Sean&#x27;s Laughing! - Will &amp; Grace (Digital Exclusive), Clip, Aired on 03/02/20" href="/will-and-grace/video/312-bloopers-seans-laughing-will-grace-digital-exclusive/4124454"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4124454"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">312 Bloopers, Sean&#x27;s Laughing! - Will &amp; Grace (Digital Exclusive)</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>03/02/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="54" aria-label="Will &amp; Grace, Jack Stands Up to a Cheerleader - Will &amp; Grace, Clip, Aired on 02/29/20" href="/will-and-grace/video/jack-stands-up-to-a-cheerleader-will-grace/4124438"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4124438"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Jack Stands Up to a Cheerleader - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>02/29/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="55" aria-label="Will &amp; Grace, Jack Tries to Get a Loan to Save Coco&#x27;s - Will &amp; Grace, Clip, Aired on 02/27/20" href="/will-and-grace/video/jack-tries-to-get-a-loan-to-save-cocos-will-grace/4123808"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4123808"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Jack Tries to Get a Loan to Save Coco&#x27;s - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>02/27/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="56" aria-label="Will &amp; Grace, Jack Tells Will to Let Go - Will &amp; Grace, Clip, Aired on 02/25/20" href="/will-and-grace/video/jack-tells-will-to-let-go-will-grace/4119848"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4119848"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Jack Tells Will to Let Go - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>02/25/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="57" aria-label="Will &amp; Grace, 311 Bloopers, Confession Time! - Will &amp; Grace (Digital Exclusive), Clip, Aired on 02/24/20" href="/will-and-grace/video/311-bloopers-confession-time-will-grace-digital-exclusive/4120416"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4120416"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">311 Bloopers, Confession Time! - Will &amp; Grace (Digital Exclusive)</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>02/24/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="58" aria-label="Will &amp; Grace, Karen Gets a Delivery from Smitty - Will &amp; Grace, Clip, Aired on 02/20/20" href="/will-and-grace/video/karen-gets-a-delivery-from-smitty-will-grace/4119842"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4119842"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Karen Gets a Delivery from Smitty - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>02/20/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="59" aria-label="Will &amp; Grace, Jack Covers His Floor with Mousetraps - Will &amp; Grace, Clip, Aired on 02/18/20" href="/will-and-grace/video/jack-covers-his-floor-with-mousetraps-will-grace/4116251"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4116251"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Jack Covers His Floor with Mousetraps - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>02/18/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="60" aria-label="Will &amp; Grace, 310 Bloopers, Watch the Insanity! - Will &amp; Grace (Digital Exclusive), Clip, Aired on 02/17/20" href="/will-and-grace/video/310-bloopers-watch-the-insanity-will-grace-digital-exclusive/4116983"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4116983"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">310 Bloopers, Watch the Insanity! - Will &amp; Grace (Digital Exclusive)</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>02/17/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="61" aria-label="Will &amp; Grace, The Rarest of Sightings: Stanley &quot;Stan&quot; Walker - Will &amp; Grace, Clip, Aired on 02/15/20" href="/will-and-grace/video/the-rarest-of-sightings-stanley-stan-walker-will-grace/4116952"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4116952"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">The Rarest of Sightings: Stanley &quot;Stan&quot; Walker - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>02/15/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="62" aria-label="Will &amp; Grace, Will and Grace Tell His Mom They&#x27;re Having Babies - Will &amp; Grace, Clip, Aired on 02/13/20" href="/will-and-grace/video/will-and-grace-tell-his-mom-theyre-having-babies-will-grace/4116247"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4116247"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Will and Grace Tell His Mom They&#x27;re Having Babies - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>02/13/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="63" aria-label="Will &amp; Grace, Will and Grace Get Lectured for This - Will &amp; Grace, Clip, Aired on 02/11/20" href="/will-and-grace/video/will-and-grace-get-lectured-for-this-will-grace/4112260"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4112260"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Will and Grace Get Lectured for This - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>02/11/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="64" aria-label="Will &amp; Grace, 309 Bloopers, You Dirty People! - Will &amp; Grace, Clip, Aired on 02/10/20" href="/will-and-grace/video/309-bloopers-you-dirty-people-will-grace/4112896"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4112896"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">309 Bloopers, You Dirty People! - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>02/10/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="65" aria-label="Will &amp; Grace, Will Jack Have Sex with Ryan Phillippe? - Will &amp; Grace, Clip, Aired on 02/06/20" href="/will-and-grace/video/will-jack-have-sex-with-ryan-phillippe-will-grace/4112258"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4112258"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Will Jack Have Sex with Ryan Phillippe? - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>02/06/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="66" aria-label="Will &amp; Grace, The Greatest Game Night Moments - Will &amp; Grace, Clip, Aired on 02/01/20" href="/will-and-grace/video/the-greatest-game-night-moments-will-grace/4109045"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4109045"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">The Greatest Game Night Moments - Will &amp; Grace</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>02/01/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="67" aria-label="Will &amp; Grace, 308 Bloopers! Featuring Demi Lovato - Will &amp; Grace (Digital Exclusive), Clip, Aired on 01/27/20" href="/will-and-grace/video/308-bloopers-featuring-demi-lovato-will-grace-digital-exclusive/4104950"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4104950"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">308 Bloopers! Featuring Demi Lovato - Will &amp; Grace (Digital Exclusive)</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>01/27/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="68" aria-label="Will &amp; Grace, Jack and Karen&#x27;s ASMR Argument - Will &amp; Grace (Episode Highlight), Clip, Aired on 01/23/20" href="/will-and-grace/video/jack-and-karens-asmr-argument-will-grace-episode-highlight/4104464"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4104464"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Jack and Karen&#x27;s ASMR Argument - Will &amp; Grace (Episode Highlight)</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>01/23/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="69" aria-label="Will &amp; Grace, Luke Breaks Up with Karen - Will &amp; Grace (Episode Highlight), Clip, Aired on 01/23/20" href="/will-and-grace/video/luke-breaks-up-with-karen-will-grace-episode-highlight/4104478"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4104478"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Luke Breaks Up with Karen - Will &amp; Grace (Episode Highlight)</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>01/23/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="70" aria-label="Will &amp; Grace, Grace Dumps a Problem on Will - Will &amp; Grace (Episode Highlight), Clip, Aired on 01/21/20" href="/will-and-grace/video/grace-dumps-a-problem-on-will-will-grace-episode-highlight/4101016"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4101016"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Grace Dumps a Problem on Will - Will &amp; Grace (Episode Highlight)</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>01/21/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="71" aria-label="Will &amp; Grace, 307 Bloopers! Excuse Me, Ma&#x27;am - Will &amp; Grace (Digital Exclusive), Clip, Aired on 01/20/20" href="/will-and-grace/video/307-bloopers-excuse-me-maam-will-grace-digital-exclusive/4101621"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4101621"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">307 Bloopers! Excuse Me, Ma&#x27;am - Will &amp; Grace (Digital Exclusive)</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>01/20/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="72" aria-label="Will &amp; Grace, Karen Walker and Beverley Leslie: A Bitter Rivalry, Clip, Aired on 01/18/20" href="/will-and-grace/video/karen-walker-and-beverley-leslie-a-bitter-rivalry/4101527"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4101527"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Karen Walker and Beverley Leslie: A Bitter Rivalry</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>01/18/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="73" aria-label="Will &amp; Grace, Jack Is Will&#x27;s Peter Pan - Will &amp; Grace (Episode Highlight), Clip, Aired on 01/16/20" href="/will-and-grace/video/jack-is-wills-peter-pan-will-grace-episode-highlight/4101012"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4101012"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Jack Is Will&#x27;s Peter Pan - Will &amp; Grace (Episode Highlight)</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>01/16/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="74" aria-label="Will &amp; Grace, Grace and Jack Go to Annie-Con, Clip, Aired on 01/14/20" href="/will-and-grace/video/grace-and-jack-go-to-anniecon/4097132"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4097132"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Grace and Jack Go to Annie-Con</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>01/14/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="75" aria-label="Will &amp; Grace, 306 Bloopers! Three Is the Magic Number - Will &amp; Grace (Digital Exclusive), Clip, Aired on 01/13/20" href="/will-and-grace/video/306-bloopers-three-is-the-magic-number-will-grace-digital-exclusive/4099501"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4099501"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">306 Bloopers! Three Is the Magic Number - Will &amp; Grace (Digital Exclusive)</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>01/13/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="76" aria-label="Will &amp; Grace, Will&#x27;s Surrogate (Demi Lovato) Is a What?, Clip, Aired on 01/09/20" href="/will-and-grace/video/wills-surrogate-demi-lovato-is-a-what/4097130"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4097130"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Will&#x27;s Surrogate (Demi Lovato) Is a What?</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>01/09/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="77" aria-label="Will &amp; Grace, The Best of Jack, Clip, Aired on 01/04/20" href="/will-and-grace/video/the-best-of-jack/4093428"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4093428"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">The Best of Jack</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>01/04/20</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="78" aria-label="Will &amp; Grace, Jingle Balls: A Will &amp; Grace Christmas, Clip, Aired on 12/21/19" href="/will-and-grace/video/jingle-balls-a-will-grace-christmas/4088245"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4088245"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Jingle Balls: A Will &amp; Grace Christmas</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>12/21/19</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="79" aria-label="Will &amp; Grace, The Best of Karen Walker, Clip, Aired on 12/07/19" href="/will-and-grace/video/the-best-of-karen-walker/4080616"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4080616"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">The Best of Karen Walker</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>12/07/19</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="80" aria-label="Will &amp; Grace, Grace Asks Karen to Be Her Baby’s Godmother, Clip, Aired on 11/26/19" href="/will-and-grace/video/grace-asks-karen-to-be-her-babys-godmother/4072369"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4072369"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Grace Asks Karen to Be Her Baby’s Godmother</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>11/26/19</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="81" aria-label="Will &amp; Grace, 305 Bloopers! What Am I Saying?, Clip, Aired on 11/25/19" href="/will-and-grace/video/305-bloopers-what-am-i-saying/4073149"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4073149"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">305 Bloopers! What Am I Saying?</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>11/25/19</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="82" aria-label="Will &amp; Grace, A Will &amp; Grace Thanksgiving, Clip, Aired on 11/23/19" href="/will-and-grace/video/a-will-grace-thanksgiving/4073052"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4073052"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">A Will &amp; Grace Thanksgiving</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>11/23/19</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="83" aria-label="Will &amp; Grace, Will Gets Help From the Grief Panda, Clip, Aired on 11/21/19" href="/will-and-grace/video/will-gets-help-from-the-grief-panda/4072331"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4072331"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Will Gets Help From the Grief Panda</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>11/21/19</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="84" aria-label="Will &amp; Grace, Grace&#x27;s Insane OB/GYN Visit, Clip, Aired on 11/19/19" href="/will-and-grace/video/graces-insane-obgyn-visit/4067981"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4067981"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Grace&#x27;s Insane OB/GYN Visit</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>11/19/19</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="85" aria-label="Will &amp; Grace, Just Bloopers! 304 Is Here, Clip, Aired on 11/18/19" href="/will-and-grace/video/just-bloopers-304-is-here/4069039"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4069039"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Just Bloopers! 304 Is Here</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>11/18/19</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="86" aria-label="Will &amp; Grace, Karen Is a Baseball Genius, Clip, Aired on 11/14/19" href="/will-and-grace/video/karen-is-a-baseball-genius/4067976"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4067976"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Karen Is a Baseball Genius</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>11/14/19</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="87" aria-label="Will &amp; Grace, Will Uncovers Jack&#x27;s Dirty Little Secret, Clip, Aired on 11/12/19" href="/will-and-grace/video/will-uncovers-jacks-dirty-little-secret/4063728"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4063728"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Will Uncovers Jack&#x27;s Dirty Little Secret</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>11/12/19</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="88" aria-label="Will &amp; Grace, Bloopers for 303 Are Coming in Hot!, Clip, Aired on 11/11/19" href="/will-and-grace/video/bloopers-for-303-are-coming-in-hot/4064629"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4064629"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Bloopers for 303 Are Coming in Hot!</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>11/11/19</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="89" aria-label="Will &amp; Grace, Will Truman: Our Favorite Control Freak, Clip, Aired on 11/09/19" href="/will-and-grace/video/will-truman-our-favorite-control-freak/4064496"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4064496"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Will Truman: Our Favorite Control Freak</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>11/09/19</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="90" aria-label="Will &amp; Grace, Karen&#x27;s Secret Money Stash, Clip, Aired on 11/07/19" href="/will-and-grace/video/karens-secret-money-stash/4063726"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4063726"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Karen&#x27;s Secret Money Stash</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>11/07/19</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="91" aria-label="Will &amp; Grace, Karen Plays DNA Detective, Clip, Aired on 11/05/19" href="/will-and-grace/video/karen-plays-dna-detective/4059439"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4059439"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Karen Plays DNA Detective</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>11/05/19</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="92" aria-label="Will &amp; Grace, Martini Time! Episode 302 Outtakes Are Here!, Clip, Aired on 11/04/19" href="/will-and-grace/video/martini-time-episode-302-outtakes-are-here/4060411"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4060411"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Martini Time! Episode 302 Outtakes Are Here!</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>11/04/19</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="93" aria-label="Will &amp; Grace, Will Breaks Jack&#x27;s Finger, Clip, Aired on 10/31/19" href="/will-and-grace/video/will-breaks-jacks-finger/4059435"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4059435"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Will Breaks Jack&#x27;s Finger</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/31/19</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="94" aria-label="Will &amp; Grace, Jack and Grace Dance to Britney Spears, Clip, Aired on 10/31/19" href="/will-and-grace/video/jack-and-grace-dance-to-britney-spears/4048673"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4048673"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Jack and Grace Dance to Britney Spears</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/31/19</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="95" aria-label="Will &amp; Grace, Oh, Honey! It&#x27;s Episode 301 Outtakes!, Clip, Aired on 10/30/19" href="/will-and-grace/video/oh-honey-its-episode-301-outtakes/4056149"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4056149"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Oh, Honey! It&#x27;s Episode 301 Outtakes!</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/30/19</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="96" aria-label="Will &amp; Grace, Will Tells McCoy He Wants a Baby, Clip, Aired on 10/29/19" href="/will-and-grace/video/will-tells-mccoy-he-wants-a-baby/4055099"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4055099"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Will Tells McCoy He Wants a Baby</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/29/19</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="97" aria-label="Will &amp; Grace, A Will &amp; Grace Halloween, Clip, Aired on 10/26/19" href="/will-and-grace/video/a-will-grace-halloween/4055904"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4055904"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">A Will &amp; Grace Halloween</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/26/19</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable tile--active tile--active" data-index="98" aria-label="Will &amp; Grace, The Making of the Will &amp; Grace Reunion, Clip, Aired on 10/24/19" href="/will-and-grace/video/the-making-of-the-will-grace-reunion/4054463"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4054463"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">The Making of the Will &amp; Grace Reunion</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/24/19</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a><a class="tile tile--clip tile--zoomable" data-index="99" aria-label="Will &amp; Grace, Estefan Throws Away Jack’s Cher Doll, Clip, Aired on 10/24/19" href="/will-and-grace/video/estefan-throws-away-jacks-cher-doll/4055091"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4055091"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Estefan Throws Away Jack’s Cher Doll</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/24/19</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></div></div><button type="button" class="shelf__arrow shelf__arrow--right" disabled=""></button></div></section></div></div></section></div></div></div><footer class="footer " role="contentinfo"><div class="footer__container"><div class="footer__logo"><a class="footer__logo__link footer__logo__link--nbc" href="/">NBC.com</a></div><section class="footer__top"><div><div class="footer__left"><div class="social-icons"><h2 class="social-icons__title">Share the Moment<span class="social-icons__trademark">™</span></h2><ul class="social-icons__icons"><li><a rel="noreferrer noopener" target="_blank" name="facebook" role="link" title="Facebook" class="social-icons__icon facebook" href="https://www.facebook.com/nbc"></a></li><li><a rel="noreferrer noopener" target="_blank" name="twitter" role="link" title="Twitter" class="social-icons__icon twitter" href="https://twitter.com/nbc"></a></li><li><a rel="noreferrer noopener" target="_blank" name="tumblr" role="link" title="Tumblr" class="social-icons__icon tumblr" href="https://nbctv.tumblr.com"></a></li><li><a rel="noreferrer noopener" target="_blank" name="pinterest" role="link" title="Pinterest" class="social-icons__icon pinterest" href="https://pinterest.com/nbctv"></a></li><li><a rel="noreferrer noopener" target="_blank" name="youtube" role="link" title="YouTube" class="social-icons__icon youtube" href="https://www.youtube.com/nbc"></a></li></ul></div></div><div class="footer__right"><div class="quick-links"><h2 class="quick-links__title">NBC Quick Links</h2><ul class="quick-links__list"><li><a href="/mvpd-picker" target="">Link TV Provider</a></li><li><a target="_blank" rel="noreferrer noopener" href="">FAQ</a></li><li><a href="/exclusives/pages/casting" target="">Casting</a></li><li><a target="_blank" rel="noreferrer noopener" href="">Contact Us</a></li><li><a href="/global/pages/tv-ratings" target="">Parental Guidelines and TV Ratings</a></li><li><a href="/tickets/pages/tickets-and-nbc-studio-tour" target="">Tickets and NBC Studio Tour</a></li><li><a href="/schedule" target="">Local Schedule</a></li></ul></div></div></div></section><div class="footer__legal"><div class="corporate-links"><ul class="corporate-links__list"><li><a href="/general/pages/accessibility" target="">Accessibility</a></li><li><a target="" rel="noreferrer noopener" href="http://www.nbcuni.com/">Corporate Info</a></li><li><a target="" rel="noreferrer noopener" href="http://www.nbcunicareers.com/">Jobs</a></li><li><a target="" rel="noreferrer noopener" href="https://www.nbcuniversal.com/privacy?intake=NBC_Entertainment">Privacy</a></li><li><a href="/general/pages/terms" target="">Terms - Updated</a></li><li><a href="/general/pages/advertise" target="">Advertise</a></li><li><a target="" rel="noreferrer noopener" href="https://www.nbcinsiders.com/">Viewer Panel</a></li><li><a target="" rel="noreferrer noopener" href="https://www.nbcuniversal.com/privacy/california-consumer-privacy-act?intake=NBC_Entertainment">CA Privacy Notice</a></li><li><a href="/general/pages/closed-captioning" target="">Closed Captioning</a></li><li><a target="" rel="noreferrer noopener" href="https://www.nbcuniversal.com/privacy/notrtoo?intake=NBC_Entertainment">Do Not Sell My Personal Information</a></li><li><a href="/general/pages/vppa" target="">Video Viewing Policy</a></li><li><a target="" rel="noreferrer noopener" href="https://www.peacocktv.com/?cid=20200101evergreenoneedi002&amp;utm_source=nbc&amp;utm_medium=oneapp_editorial_footer_footerlink&amp;utm_campaign=20200101evergreen&amp;utm_term=weblink&amp;utm_content=footerlink">Peacock</a></li></ul></div></div></div><div class="footer__base"><ul class="footer__base__list"><li>A Division of <strong>NBCUniversal</strong></li><li><a href="https://www.nbcuniversal.com/privacy/cookies#cookie_management" target="_blank" rel="noopener noreferrer">Ad Choices</a></li><li>©<!-- -->2020<!-- --> NBCUniversal Media, LLC</li></ul></div></footer><div class="responsive-app__cookies"><div class="responsive-app__cookies__wrapper"><div class="responsive-app__cookies__inner"><div class="responsive-app__cookies__text">We and our partners use cookies on this site to improve our service, perform analytics, personalize advertising, measure advertising performance, and remember website preferences. By using the site, you consent to these cookies. For more information on cookies including how to manage your consent visit our<!-- --> <a target="_blank" href="https://www.nbcuniversal.com/privacy/cookies" rel="noopener noreferrer">cookie policy</a>.</div><button class="button" type="button"><span><i></i>Continue</span></button></div></div></div></main></div></div>
        <script>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</script>
        <div id="scripts" data-reactroot=""><script src="/generetic/scripts/ads.js"></script><script src="https://entitlement.auth.adobe.com/entitlement/v4/AccessEnabler.js"></script><script src="https://pdk.theplatform.com/5.8.7/pdk/tpPdkController.js"></script><script src="/generetic/scripts/nbcd_appmeasurement_2_11.js" async=""></script></div>
        <script async src=/generetic/generated/chunks/48.532a8780e6c10b0f6228.js></script>
<script async src=/generetic/generated/generetic.b7b65e15a4899beea938.js></script>
<script async src=/generetic/generated/chunks/0.cd1ea8000e29d103b332.js></script>
<script async src=/generetic/generated/chunks/1.3468a70e4fa4274b234a.js></script>
<script async src=/generetic/generated/chunks/10.e9b1113811c90682e79c.js></script>
<script async src=/generetic/generated/chunks/2.276788b3b9644cb43b5f.js></script>
<script async src=/generetic/generated/chunks/43.b1ab5ba7e562738b32ed.js></script>
      </body>
    </html>