<!DOCTYPE html><html lang="en-US" class="responsive">
      <head>
        
          <script type="text/javascript" data-platform="web" data-params='{"name":"saturday-night-live/video/out-of-africa/2724274","type":"VIDEO"}'>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</script>
        
        <link rel="preload" as="style" href="/generetic/generated/49.generetic.59239f75f34dab3a6742.css" />
<link rel="preload" as="script" href="/generetic/generated/chunks/49.daab4515db71b9d1c9b9.js" />
<link rel="preload" as="style" href="/generetic/generated/generetic.25196cf0ab7fda21f3e7.css" />
<link rel="preload" as="script" href="/generetic/generated/generetic.58d32494dd967e443a10.js" />
<link rel="preload" as="script" href="/generetic/generated/chunks/0.1a3d19e45973dcdc73d8.js" />
<link rel="preload" as="script" href="/generetic/generated/chunks/1.36554331d0745b8b6c7d.js" />
<link rel="preload" as="script" href="/generetic/generated/chunks/10.9fb03abd5c59f1eb46d6.js" />
<link rel="preload" as="script" href="/generetic/generated/chunks/2.e16593e99498ef344128.js" />
<link rel="preload" as="script" href="/generetic/generated/chunks/44.8a959bd0f205431b28c8.js" />
        <link rel="stylesheet" href=/generetic/generated/49.generetic.59239f75f34dab3a6742.css />
<link rel="stylesheet" href=/generetic/generated/generetic.25196cf0ab7fda21f3e7.css />
        <link rel="preload" as="font" href="/generetic/generated/fonts/SourceSansProRegular.woff2" type="font/woff2" crossorigin />
<link rel="preload" as="font" href="/generetic/generated/fonts/SourceSansProSemiBold.woff2" type="font/woff2" crossorigin />
<link rel="preload" as="font" href="/generetic/generated/fonts/SourceSansProLight.woff2" type="font/woff2" crossorigin />
<link rel="preload" as="font" href="/generetic/generated/fonts/MontserratRegular.woff2" type="font/woff2" crossorigin />
<link rel="preload" as="font" href="/generetic/generated/fonts/MontserratBold.woff2" type="font/woff2" crossorigin />
        <title data-reactroot="">Watch Saturday Night Live Highlight: Out of Africa - NBC.com</title><meta name="description" content="Watch Saturday Night Live highlight &#x27;Out of Africa&#x27; on NBC.com" data-reactroot=""/><meta property="og:type" content="video.other" data-reactroot=""/><meta property="og:title" content="Watch Saturday Night Live Highlight: Out of Africa - NBC.com" data-reactroot=""/><meta property="og:description" content="Watch Saturday Night Live highlight &#x27;Out of Africa&#x27; on NBC.com" data-reactroot=""/><meta property="og:image" content="https://img.nbc.com/sites/nbcunbc/files/images/2021/5/19/c1a2b78f0303ada95a7494363ab6e81e_d7f2fbc1a110150b05a4ac9a268c4b7e.jpg" data-reactroot=""/><meta property="og:image:type" content="image/jpeg" data-reactroot=""/><meta property="og:image:width" content="640" data-reactroot=""/><meta property="og:image:height" content="360" data-reactroot=""/><meta name="twitter:title" content="Watch Saturday Night Live Highlight: Out of Africa - NBC.com" data-reactroot=""/><meta name="twitter:image" content="https://img.nbc.com/sites/nbcunbc/files/images/2021/5/19/c1a2b78f0303ada95a7494363ab6e81e_d7f2fbc1a110150b05a4ac9a268c4b7e.jpg" data-reactroot=""/><meta name="twitter:card" content="app" data-reactroot=""/><meta name="twitter:description" content="Watch Saturday Night Live highlight &#x27;Out of Africa&#x27; on NBC.com" data-reactroot=""/><meta name="twitter:app:url:iphone" content="nbctve://video/2724274" data-reactroot=""/><meta name="twitter:app:url:ipad" content="nbctve://video/2724274" data-reactroot=""/><meta name="twitter:app:url:googleplay" content="nbctve://video/2724274" data-reactroot=""/><link rel="canonical" href="https://www.nbc.com/saturday-night-live/video/out-of-africa/2724274" data-reactroot=""/><meta property="og:video" content="https://pdk.theplatform.com/current/pdk/swf/flvPlayer.swf?id=player&amp;v=%2F%2Fplayer.theplatform.com%2Fp%2FNnzsPC%2Fwidget%2Fconfig%2Fselect%2Fmedia%2Fguid%2F2410887629%2F2724274%3Ffwsitesection%3Dnbc_video_vod_embed%26form%3Dvars%26component%3Dplayer%26autoPlay%3Dtrue%26referrer%3Dfacebook" data-reactroot=""/><meta property="og:video:secure_url" content="https://pdk.theplatform.com/current/pdk/swf/flvPlayer.swf?id=player&amp;v=%2F%2Fplayer.theplatform.com%2Fp%2FNnzsPC%2Fwidget%2Fconfig%2Fselect%2Fmedia%2Fguid%2F2410887629%2F2724274%3Ffwsitesection%3Dnbc_video_vod_embed%26form%3Dvars%26component%3Dplayer%26autoPlay%3Dtrue%26referrer%3Dfacebook" data-reactroot=""/><meta property="video:duration" content="184" data-reactroot=""/><meta property="video:series" content="Saturday Night Live" data-reactroot=""/><meta property="video:tag" content="Clip" data-reactroot=""/><meta property="video:release_date" content="1993-09-24" data-reactroot=""/><script type="application/ld+json" data-reactroot="">{"@context":"https://schema.org","@id":"2724274","@type":"TVClip","name":"Out of Africa","description":"This Out of Africa store holds artifacts that are primarily used to hide marijuana.","video":{"@type":"VideoObject","name":"Out of Africa","description":"This Out of Africa store holds artifacts that are primarily used to hide marijuana.","embedURL":"//player.theplatform.com/p/NnzsPC/widget/config/select/media/guid/2410887629/2724274?fwsitesection=nbc_video_vod_embed","uploadDate":"1993-09-24T06:30:00.000Z","thumbnailUrl":"https://img.nbc.com/sites/nbcunbc/files/images/2021/5/19/c1a2b78f0303ada95a7494363ab6e81e_d7f2fbc1a110150b05a4ac9a268c4b7e.jpg","potentialAction":[{"@type":"WatchAction","target":{"@type":"EntryPoint","inLanguage":"EN","urlTemplate":"/saturday-night-live/video/out-of-africa/2724274","actionPlatform":"http://schema.org/DesktopWebPlatform"},"expectsAcceptanceOf":[{"@type":"Offer","category":"free","eligibleRegion":[{"@type":"Country","name":"GU"},{"@type":"Country","name":"MP"},{"@type":"Country","name":"PR"},{"@type":"Country","name":"US"},{"@type":"Country","name":"VI"}]}]},{"@type":"WatchAction","target":{"@type":"EntryPoint","inLanguage":"EN","urlTemplate":"/saturday-night-live/video/out-of-africa/2724274","actionPlatform":"http://schema.org/MobileWebPlatform"},"expectsAcceptanceOf":[{"@type":"Offer","category":"free","eligibleRegion":[{"@type":"Country","name":"GU"},{"@type":"Country","name":"MP"},{"@type":"Country","name":"PR"},{"@type":"Country","name":"US"},{"@type":"Country","name":"VI"}]}]}],"url":"/saturday-night-live/video/out-of-africa/2724274"},"partOfSeries":{"@type":"TVSeries","name":"Saturday Night Live","sameAs":"https://www.imdb.com/title/tt0072562/","url":"https://www.nbc.com/saturday-night-live","description":"Saturdays at 11:30 p.m., live coast-to-coast. NBC's Emmy-winning late-night comedy showcase enters its 45th season."},"partOfSeason":{"@type":"TVSeason","seasonNumber":"19"}}</script><meta charSet="utf-8" data-reactroot=""/><meta name="viewport" content="width=device-width, initial-scale=1" data-reactroot=""/><meta name="apple-media-service-subscription" content="expires=9999, type=free" data-reactroot=""/><meta property="fb:app_id" content="653521154659171" data-reactroot=""/><meta property="og:site_name" content="NBC" data-reactroot=""/><meta property="og:url" content="https://www.nbc.com/saturday-night-live/video/out-of-africa/2724274" data-reactroot=""/><meta property="al:android:package" content="com.nbcuni.nbc" data-reactroot=""/><meta property="al:android:app_name" content="NBC" data-reactroot=""/><meta property="al:ios:app_store_id" content="442839435" data-reactroot=""/><meta property="al:ios:app_name" content="NBC" data-reactroot=""/><meta property="al:ipad:app_store_id" content="442839435" data-reactroot=""/><meta property="al:ipad:app_name" content="NBC" data-reactroot=""/><meta property="al:iphone:app_store_id" content="442839435" data-reactroot=""/><meta property="al:iphone:app_name" content="NBC" data-reactroot=""/><meta property="al:web:url" content="https://www.nbc.com/saturday-night-live/video/out-of-africa/2724274" data-reactroot=""/><meta property="al:web:should_fallback" content="true" data-reactroot=""/><meta name="twitter:site" content="@nbc" data-reactroot=""/><meta name="twitter:site:id" content="26585095" data-reactroot=""/><meta name="twitter:url" content="https://www.nbc.com/saturday-night-live/video/out-of-africa/2724274" data-reactroot=""/><meta name="twitter:app:country" content="US" data-reactroot=""/><meta name="twitter:app:name:iphone" content="NBC" data-reactroot=""/><meta name="twitter:app:id:iphone" content="442839435" data-reactroot=""/><meta name="twitter:app:name:ipad" content="NBC" data-reactroot=""/><meta name="twitter:app:id:ipad" content="442839435" data-reactroot=""/><meta name="twitter:app:name:googleplay" content="NBC" data-reactroot=""/><meta name="twitter:app:id:googleplay" content="com.nbcuni.nbc" data-reactroot=""/><meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" data-reactroot=""/><link rel="alternate" href="https://www.nbc.com/saturday-night-live/video/out-of-africa/2724274" hrefLang="en" data-reactroot=""/><link rel="alternate" href="https://www.nbc.com/saturday-night-live/video/out-of-africa/2724274?lang=es" hrefLang="es" data-reactroot=""/><link rel="shortcut icon" href="/generetic/favicon.ico" data-reactroot=""/><link rel="icon" href="/generetic/favicon.ico" data-reactroot=""/><link rel="apple-touch-icon" href="/generetic/images/apple-touch-icon.png" data-reactroot=""/>
        <link rel="preconnect" href="https://identity.mparticle.com">
        <link rel="preconnect" href="https://friendship.nbc.co">
        <link rel="dns-prefetch" href="https://identity.mparticle.com">
        <link rel="dns-prefetch" href="https://friendship.nbc.co">
        <link rel="dns-prefetch" href="https://static.vilynx.com">
        <link rel="dns-prefetch" href="https://public.vilynx.com">
      
                          <script>!function(a){var e="https://s.go-mpulse.net/boomerang/",t="addEventListener";if("False"=="True")a.BOOMR_config=a.BOOMR_config||{},a.BOOMR_config.PageParams=a.BOOMR_config.PageParams||{},a.BOOMR_config.PageParams.pci=!0,e="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="P9G88-GQ2QU-M824B-4WKRW-LBG3T",function(){function n(e){a.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!a.BOOMR||!a.BOOMR.version&&!a.BOOMR.snippetExecuted){a.BOOMR=a.BOOMR||{},a.BOOMR.snippetExecuted=!0;var i,_,o,r=document.createElement("iframe");if(a[t])a[t]("load",n,!1);else if(a.attachEvent)a.attachEvent("onload",n);r.src="javascript:void(0)",r.title="",r.role="presentation",(r.frameElement||r).style.cssText="width:0;height:0;border:0;display:none;",o=document.getElementsByTagName("script")[0],o.parentNode.insertBefore(r,o);try{_=r.contentWindow.document}catch(O){i=document.domain,r.src="javascript:var d=document.open();d.domain='"+i+"';void(0);",_=r.contentWindow.document}_.open()._l=function(){var a=this.createElement("script");if(i)this.domain=i;a.id="boomr-if-as",a.src=e+"P9G88-GQ2QU-M824B-4WKRW-LBG3T",BOOMR_lstart=(new Date).getTime(),this.body.appendChild(a)},_.write("<bo"+'dy onload="document._l();">'),_.close()}}(),"".length>0)if(a&&"performance"in a&&a.performance&&"function"==typeof a.performance.setResourceTimingBufferSize)a.performance.setResourceTimingBufferSize();!function(){if(BOOMR=a.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var e=""=="true"?1:0,t="",n="nml5ubdik5khwygummeq-f-c8b146c6b-clientnsv4-s.akamaihd.net",i={"ak.v":"31","ak.cp":"260350","ak.ai":parseInt("157040",10),"ak.ol":"0","ak.cr":1,"ak.ipv":4,"ak.proto":"http/1.1","ak.rid":"1ed5b090","ak.r":40759,"ak.a2":e,"ak.m":"dscb","ak.n":"essl","ak.bpcip":"107.23.218.0","ak.cport":43028,"ak.gh":"104.78.78.103","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"reno","ak.t":"1624531721","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==91lddiMdYzi8mN3xE0BvGYgk1Gk5/HxxCKLHbnYeGz4sxmSywYpb5xItQCpPlko8EMMVxCgNui6zXGMEkTa5M5nOADo8ormYi+mYmsVdNYN8hphrink1a8nTjzEYsHODOJ5xmnz22TgTUlHZ1qOjE48cuWIgum7ewMotOApiYv60M1tIdX+MSE7Yf5jggPsVDf5SYKGx32ROKmPDxwm2ASPK4Q3iotxCDzWgpQvIX7Ccx9QBBQGaWosij7KI0cTElLr6I1XeslYm4UuXjyxFTODclZDq+vNC/Ojwvj8D00YZ4Fs2D5ERm7GHPHN+VX5ay5iL/KAYhKzS31RgLCX2x3QKp7iuy8my+AOSGf8XzgSuXmz/esc3oTEu6s5fwAfPkWfu0f1ZtElqJpW5DmbMej9CwqDm8aES+ZIP4/H/eEA=","ak.pv":"442","ak.dpoabenc":""};if(""!==t)i["ak.ruds"]=t;var _={i:!1,av:function(e){var t="http.initiator";if(e&&(!e[t]||"spa_hard"===e[t]))i["ak.feo"]=void 0!==a.aFeoApplied?1:0,BOOMR.addVar(i)},rv:function(){var a=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t"];BOOMR.removeVar(a)}};BOOMR.plugins.AK={akVars:i,akDNSPreFetchDomain:n,init:function(){if(!_.i){var a=BOOMR.subscribe;a("before_beacon",_.av,null,null),a("onbeacon",_.rv,null,null),_.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head>
      <body>
        <div id="app"><div class="responsive-app" data-reactroot=""><header class="responsive-app__header"><nav role="navigation" class="navigation navigation--sticky"><div class="navigation__inner"><div class="navigation__logo-wrapper"><div class="navigation__item navigation__item--accessibility navigation__item--hidden"><a href="#main-content" class="navigation__accessibility-button"><span>Skip to Content</span></a></div><a class="navigation__logo navigation__logo--nbc" href="/">NBC.com</a><div class="navigation__mobile--wrapper"><button type="button" class="navigation__search navigation__search--mobile" aria-label="Toggle site search"><span></span></button><button type="button" class="navigation__hamburger" aria-label="Toggle main navigation"></button></div></div><ul class="navigation__list navigation__list--nbc navigation__list--show-page" style="margin-top:0"><li class="navigation__item navigation__item--nbc-label"><span class="navigation__item__title">NBC.com</span></li><li class="navigation__item navigation__item--home"><a class="navigation__item__link" href="/"><span class="navigation__item__title">Home</span></a></li><li class="navigation__item navigation__item--shows"><a class="navigation__item__link" href="/shows/all/popular"><span class="navigation__item__title navigation__item__title--no-transform">Shows</span></a></li><li class="navigation__item navigation__item--movies"><a class="navigation__item__link" href="/movies/popular"><span class="navigation__item__title navigation__item__title--no-transform">Movies</span></a></li><li class="navigation__item"><a class="navigation__item__link" href="/networks"><span class="navigation__item__title">Networks</span></a></li><li class="navigation__item navigation__item--live"><a class="navigation__item__link" href="/live"><span class="navigation__item__title">Live</span></a></li><li class="navigation__item"><a class="navigation__item__link" href="/apps?brand=nbc"><span class="navigation__item__title">App</span></a></li><li class="navigation__item"><a class="navigation__item__link" href="https://www.nbcstore.com/?cid=nbc_global_nav_shop"><span class="navigation__item__title">Shop</span></a></li><li class="navigation__item navigation__item--search"><button type="button" class="navigation__search navigation__item__title" aria-label="Toggle site search"><span></span></button></li><div class="navigation__identity--block"><li class="navigation__item navigation__item--identity"><div class="navigation__item__spinner"><div class="spinner spinner--relative spinner--small spinner--light" theme="light" style="top:19px"><span style="animation-delay:-1.2s;transform:rotate(0deg) translate(146%)"></span><span style="animation-delay:-1.1s;transform:rotate(30deg) translate(146%)"></span><span style="animation-delay:-1s;transform:rotate(60deg) translate(146%)"></span><span style="animation-delay:-0.9s;transform:rotate(90deg) translate(146%)"></span><span style="animation-delay:-0.8s;transform:rotate(120deg) translate(146%)"></span><span style="animation-delay:-0.7s;transform:rotate(150deg) translate(146%)"></span><span style="animation-delay:-0.6s;transform:rotate(180deg) translate(146%)"></span><span style="animation-delay:-0.5s;transform:rotate(210deg) translate(146%)"></span><span style="animation-delay:-0.4s;transform:rotate(240deg) translate(146%)"></span><span style="animation-delay:-0.3s;transform:rotate(270deg) translate(146%)"></span><span style="animation-delay:-0.2s;transform:rotate(300deg) translate(146%)"></span><span style="animation-delay:-0.1s;transform:rotate(330deg) translate(146%)"></span></div></div></li></div></ul></div></nav></header><div id="contentAccessEnabler"></div><main id="main" role="main" class="responsive-app__main"><div class="screen-reader"><p tabindex="-1" id="main-content">Main Content</p></div><div class="responsive-app__wrapper responsive-app__wrapper--nbc"><div class="video-page"><div class="video-page__sections"><div class="sticky-outer-wrapper show-header"><div class="sticky-inner-wrapper" style="position:relative;top:0px"><div class="show-header__background" style="background-image:linear-gradient(95deg, #155a92, #232b40)"><div class="show-header__info"><div class="show-header__title"><span class="show-header__title__inner">Saturday Night Live</span></div><div class="show-header__tune-in">SATURDAYS | 11:30ET 10:30CT 9:30MT 8:30PT</div></div><div class="show-header__toggle-favorite"><a class="navigation__item__link navigation__item__link--favorite-add" aria-label="Add To Favorites" data-tip="Added to Favorites" style="color:#155a92" role="tab" tabindex="0"><i class="show-header__add-favorite-icon"></i></a></div></div><div class="show-header__menu"><ul class="show-header__list"><li class="navigation__item__desktop-only"><a class="navigation__item__link navigation__item__link--favorite-add" aria-label="Add To Favorites" data-tip="Added to Favorites" style="color:#155a92" role="tab" tabindex="0"><i class="show-header__add-favorite-icon"></i></a></li><li class="navigation__item__link navigation__item__link--div" style="color:#155a92"><a class="navigation__item__link navigation__item__link_target" href="/saturday-night-live" target="" aria-label="Main" role="tab">main</a></li><li class="navigation__item__link navigation__item__link--div" style="color:#155a92"><a class="navigation__item__link navigation__item__link_target" href="/saturday-night-live/episodes" target="" aria-label="Episodes" role="tab">episodes</a></li><li class="navigation__item__link navigation__item__link--div" style="color:#155a92"><a class="navigation__item__link navigation__item__link_target" href="/saturday-night-live/photos" target="" aria-label="Photos" role="tab">photos</a></li><li class="navigation__item__link navigation__item__link--div" style="color:#155a92"><a class="navigation__item__link navigation__item__link_target" href="/saturday-night-live/credits/cast" target="" aria-label="Cast" role="tab">cast</a></li><li class="navigation__item__link navigation__item__link--div" style="color:#155a92"><a target="_blank" rel="noreferrer noopener" class="navigation__item__link navigation__item__link_target" href="https://www.nbcstore.com/shop-by-show/saturday-night-live.html#utm_source=NBC&amp;utm_medium=Banner&amp;utm_campaign=saturday-night-live" aria-label="Shop" role="tab">shop</a></li></ul></div><div class="__react_component_tooltip place-right type-dark" data-id="tooltip"></div></div></div><section class="video-page__player video-page__player--isZoomable"><div class="video-page__player--inner"><div class="video-page__spinner"><div class="video-page__spinner__wrapper"><div class="spinner spinner--relative spinner--light" theme="light" style="top:50%"><span style="animation-delay:-1.2s;transform:rotate(0deg) translate(146%)"></span><span style="animation-delay:-1.1s;transform:rotate(30deg) translate(146%)"></span><span style="animation-delay:-1s;transform:rotate(60deg) translate(146%)"></span><span style="animation-delay:-0.9s;transform:rotate(90deg) translate(146%)"></span><span style="animation-delay:-0.8s;transform:rotate(120deg) translate(146%)"></span><span style="animation-delay:-0.7s;transform:rotate(150deg) translate(146%)"></span><span style="animation-delay:-0.6s;transform:rotate(180deg) translate(146%)"></span><span style="animation-delay:-0.5s;transform:rotate(210deg) translate(146%)"></span><span style="animation-delay:-0.4s;transform:rotate(240deg) translate(146%)"></span><span style="animation-delay:-0.3s;transform:rotate(270deg) translate(146%)"></span><span style="animation-delay:-0.2s;transform:rotate(300deg) translate(146%)"></span><span style="animation-delay:-0.1s;transform:rotate(330deg) translate(146%)"></span></div></div></div></div></section><div class="video-meta"><div class="video-meta__container"><div class="video-meta__inner"><h1 class="video-meta__title"><span>Out of Africa</span></h1><div class="video-meta__secondary-title"><span class="video-meta__badge">CLIP</span><span>09/25/93</span></div><div class="video-meta__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div><button type="button" class="video-meta__expand"><span class="video-meta__expand__text" style="background-color:#155a92">Details</span></button></div></div></div><div class="video-meta__expandable"><div class="video-meta__details-container"><div class="video-meta__details"><a class="video-meta__app-link" href="/apps" tabindex="-1"><span class="video-meta__app-link__text">Also available on the <!-- -->nbc<!-- --> app</span></a><p class="video-meta__description">This Out of Africa store holds artifacts that are primarily used to hide marijuana.</p><div class="video-meta__appearing"><span class="video-meta__appearing-title">Appearing:</span></div><div class="video-meta__tags">Tags: 1990, Marijuana store, Africa store, Africa weed store, Weed hiding store, &quot;Put your weed in it&quot;, Charles Barkley Africa store, Charles Barkley weed store, Charles Barkley police</div><div class="video-meta__info"><span class="video-meta__episode">S19 E1</span><span class="video-meta__length">3 min</span><span class="video-meta__type">Highlight</span><span class="video-meta__show-type">Comedy</span><span class="video-meta__show-air-type">Late Night</span></div><div class="video-meta__copyright">-</div><div class="share"><a class="share__btn share__btn--facebook" aria-label="Share on Facebook" rel="noreferrer noopener" target="_blank" title="Facebook" href="https://www.facebook.com/sharer/sharer.php?u=" tabindex="-1"></a><a class="share__btn share__btn--twitter" aria-label="Share on Twitter" rel="noreferrer noopener" target="_blank" title="Twitter" href="https://twitter.com/intent/tweet?text=Watch%2009%2F25%2F93%20from%20Saturday%20Night%20Live%20on%20NBC.com&amp;url=" tabindex="-1"></a></div></div></div></div><section class="links-selectable-group"><div class="links-selectable-group__container"><div class="links-selectable-group__inner"><div class="filter-select"><button type="button" class="filter-select__inner" aria-haspopup="listbox" aria-labelledby="undefined undefined" aria-label="Most Recent" aria-expanded="false"><span class="filter-select__selected">Most Recent</span></button><ul class="filter-select__dropdown" role="listbox" tabindex="-1" aria-activedescendant="undefined-Most Recent"><li class="filter-select__item" role="option" aria-selected="true" id="undefined-Most Recent" tabindex="0"><span class="filter-select__link">Most Recent</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Behind the Scenes" tabindex="0"><span class="filter-select__link">Behind the Scenes</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Current Preview" tabindex="0"><span class="filter-select__link">Current Preview</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Excerpt" tabindex="0"><span class="filter-select__link">Excerpt</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Highlight" tabindex="0"><span class="filter-select__link">Highlight</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Sneak Peek" tabindex="0"><span class="filter-select__link">Sneak Peek</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Web Exclusive" tabindex="0"><span class="filter-select__link">Web Exclusive</span></li></ul></div><section class="shelf shelf--default shelf--ClipTile"><div class="section-heading section-heading--text"><h2 class="section-heading__title" id="section-heading-clips">Clips</h2></div><div class="shelf__inner"><button type="button" class="shelf__arrow shelf__arrow--left" disabled="" aria-hidden="true"></button><div class="shelf__tiles"><ul class="shelf__tiles__inner" style="transform:translate3d(0px, 0, 0)" aria-labelledby="section-heading-clips"><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="0" aria-label="Saturday Night Live, Season 46 Finale Cold Open, Clip, Aired on 05/22/21" href="/saturday-night-live/video/season-46-finale-cold-open/4367115"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367115"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Season 46 Finale Cold Open</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="1" aria-label="Saturday Night Live, Anya Taylor-Joy Monologue, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/anya-taylorjoy-monologue/4367116"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367116"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Anya Taylor-Joy Monologue</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="2" aria-label="Saturday Night Live, Weekend Update: Colin Jost and Michael Che Swap Jokes for Season 46 Finale, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-colin-jost-and-michael-che-swap-jokes-for-season-46-finale/4367127"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367127"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Colin Jost and Michael Che Swap Jokes for Season 46 Finale</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="3" aria-label="Saturday Night Live, Weekend Update: Pete Davidson on Mental Health and the COVID-19  Pandemic, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-pete-davidson-on-mental-health-and-the-covid19-pandemic/4367125"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367125"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Pete Davidson on Mental Health and the COVID-19  Pandemic</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="4" aria-label="Saturday Night Live, Pride Month Song, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/pride-month-song/4367130"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367130"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Pride Month Song</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="5" aria-label="Saturday Night Live, College Panel, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/college-panel/4367119"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367119"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">College Panel</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="6" aria-label="Saturday Night Live, Hollywood Squares, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/hollywood-squares/4367120"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367120"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Hollywood Squares</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="7" aria-label="Saturday Night Live, Making Man, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/making-man/4367117"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367117"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Making Man</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="8" aria-label="Saturday Night Live, Lingerie Store, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/lingerie-store/4367133"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367133"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Lingerie Store</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="9" aria-label="Saturday Night Live, Celtic Woman, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/celtic-woman/4367122"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367122"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Celtic Woman</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="10" aria-label="Saturday Night Live, Weekend Update:  Republicans to Block January 6 Investigation, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-republicans-to-block-january-6-investigation/4367124"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367124"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update:  Republicans to Block January 6 Investigation</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="11" aria-label="Saturday Night Live, Picture with Dad, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/picture-with-dad/4367121"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367121"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Picture with Dad</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="12" aria-label="Saturday Night Live, Weekend Update: Jeanine Pirro on the Mexico–United States border, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-jeanine-pirro-on-the-mexicounited-states-border/4367128"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367128"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Jeanine Pirro on the Mexico–United States border</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="13" aria-label="Saturday Night Live, Weekend Update: Marilyn Manson Sued, Helen Keller Doll, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-marilyn-manson-sued-helen-keller-doll/4367126"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367126"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Marilyn Manson Sued, Helen Keller Doll</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="14" aria-label="Saturday Night Live, AMC Theatres Commercial, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/amc-theatres-commercial/4367129"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367129"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">AMC Theatres Commercial</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="15" aria-label="Saturday Night Live, Backstage Pitch, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/backstage-pitch/4367118"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367118"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Backstage Pitch</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="16" aria-label="Saturday Night Live, Every Close Encounter Ever: Part 1, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/every-close-encounter-ever-part-1/4383676"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4383676"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Every Close Encounter Ever: Part 1</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="17" aria-label="Saturday Night Live, Star Quality, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/star-quality/4368580"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4368580"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Star Quality</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="18" aria-label="Saturday Night Live, Anya Taylor-Joy and Lil Nas X Agree This Finale Is the Best SNL Show of the Season, Clip, Aired on 05/20/21" tabindex="-1" href="/saturday-night-live/video/anya-taylorjoy-and-lil-nas-x-agree-this-finale-is-the-best-snl-show-of-the-season/4365816"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4365816"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Anya Taylor-Joy and Lil Nas X Agree This Finale Is the Best SNL Show of the Season</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/20/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="19" aria-label="Saturday Night Live, No More Masks Cold Open, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/no-more-masks-cold-open/4362992"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4362992"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">No More Masks Cold Open</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="20" aria-label="Saturday Night Live, Keegan-Michael Key Monologue, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/keeganmichael-key-monologue/4362993"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4362993"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Keegan-Michael Key Monologue</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="21" aria-label="Saturday Night Live, Weekend Update: CDC Lifts Mask Mandate, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-cdc-lifts-mask-mandate/4363000"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4363000"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: CDC Lifts Mask Mandate</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="22" aria-label="Saturday Night Live, Weekend Update: Liz Cheney on the Republican Party, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-liz-cheney-on-the-republican-party/4363003"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4363003"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Liz Cheney on the Republican Party</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="23" aria-label="Saturday Night Live, The Muppet Show, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/the-muppet-show/4362996"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4362996"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">The Muppet Show</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="24" aria-label="Saturday Night Live, Weekend Update: Tom Cruise Returns Golden Globes &amp; Ohio State Massage Therapist, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-tom-cruise-returns-golden-globes-ohio-state-massage-therapist/4363001"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4363001"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Tom Cruise Returns Golden Globes &amp; Ohio State Massage Therapist</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="25" aria-label="Saturday Night Live, Weekend Update: Andrew Dismukes on Great-Grandmas, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-andrew-dismukes-on-greatgrandmas/4363002"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4363002"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Andrew Dismukes on Great-Grandmas</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="26" aria-label="Saturday Night Live, High School Graduation, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/high-school-graduation/4362994"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4362994"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">High School Graduation</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="27" aria-label="Saturday Night Live, Gemma &amp; DJ Balls, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/gemma-dj-balls/4362998"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4362998"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Gemma &amp; DJ Balls</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="28" aria-label="Saturday Night Live, Prom Show, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/prom-show/4363006"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4363006"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Prom Show</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="29" aria-label="Saturday Night Live, Sending Drinks, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/sending-drinks/4363005"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4363005"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Sending Drinks</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="30" aria-label="Saturday Night Live, The Last Dance: Extended Scene, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/the-last-dance-extended-scene/4362995"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4362995"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">The Last Dance: Extended Scene</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="31" aria-label="Saturday Night Live, Weekend Update: Bob Baffert on Medina Spirit’s Failed Drug Test, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-bob-baffert-on-medina-spirits-failed-drug-test/4363004"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4363004"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Bob Baffert on Medina Spirit’s Failed Drug Test</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="32" aria-label="Saturday Night Live, Rap Diss, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/rap-diss/4362997"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4362997"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Rap Diss</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="33" aria-label="Saturday Night Live, Keegan-Michael Key Promises the Best SNL in 46 Years, Clip, Aired on 05/13/21" tabindex="-1" href="/saturday-night-live/video/keeganmichael-key-promises-the-best-snl-in-46-years/4362032"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4362032"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Keegan-Michael Key Promises the Best SNL in 46 Years</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/13/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="34" aria-label="Saturday Night Live, Mother’s Day Message Cold Open, Clip, Aired on 05/08/21" tabindex="-1" href="/saturday-night-live/video/mothers-day-message-cold-open/4358910"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4358910"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Mother’s Day Message Cold Open</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/08/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="35" aria-label="Saturday Night Live, Elon Musk Monologue, Clip, Aired on 05/08/21" tabindex="-1" href="/saturday-night-live/video/elon-musk-monologue/4358911"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4358911"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Elon Musk Monologue</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/08/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="36" aria-label="Saturday Night Live, Weekend Update: Rocket Crashes to Earth, Clip, Aired on 05/08/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-rocket-crashes-to-earth/4358917"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4358917"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Rocket Crashes to Earth</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/08/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="37" aria-label="Saturday Night Live, Weekend Update: Financial Expert Lloyd Ostertag on Cryptocurrency, Clip, Aired on 05/08/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-financial-expert-lloyd-ostertag-on-cryptocurrency/4358919"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4358919"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Financial Expert Lloyd Ostertag on Cryptocurrency</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/08/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="38" aria-label="Saturday Night Live, Chad on Mars, Clip, Aired on 05/08/21" tabindex="-1" href="/saturday-night-live/video/chad-on-mars/4358923"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4358923"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Chad on Mars</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/08/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="39" aria-label="Saturday Night Live, Gen Z Hospital, Clip, Aired on 05/08/21" tabindex="-1" href="/saturday-night-live/video/gen-z-hospital/4358915"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4358915"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Gen Z Hospital</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/08/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="40" aria-label="Saturday Night Live, Weekend Update: Baby Yoda on Star Wars Day Celebrations, Clip, Aired on 05/08/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-baby-yoda-on-star-wars-day-celebrations/4358921"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4358921"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Baby Yoda on Star Wars Day Celebrations</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/08/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="41" aria-label="Saturday Night Live, Post-Quarantine Conversation, Clip, Aired on 05/08/21" tabindex="-1" href="/saturday-night-live/video/postquarantine-conversation/4358912"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4358912"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Post-Quarantine Conversation</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/08/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="42" aria-label="Saturday Night Live, Cowboy Standoff, Clip, Aired on 05/08/21" tabindex="-1" href="/saturday-night-live/video/cowboy-standoff/4358926"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4358926"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Cowboy Standoff</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/08/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="43" aria-label="Saturday Night Live, Weekend Update: A Weary Mother in Her Darkest Hour on Disney&#x27;s Reopening, Clip, Aired on 05/08/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-a-weary-mother-in-her-darkest-hour-on-disneys-reopening/4358918"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4358918"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: A Weary Mother in Her Darkest Hour on Disney&#x27;s Reopening</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/08/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="44" aria-label="Saturday Night Live, Wario, Clip, Aired on 05/08/21" tabindex="-1" href="/saturday-night-live/video/wario/4358922"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4358922"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Wario</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/08/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="45" aria-label="Saturday Night Live, Weekend Update: The Bidens and Carters Take a Picture &amp; the Most Instagrammable Bird, Clip, Aired on 05/08/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-the-bidens-and-carters-take-a-picture-the-most-instagrammable-bird/4358920"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4358920"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: The Bidens and Carters Take a Picture &amp; the Most Instagrammable Bird</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/08/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="46" aria-label="Saturday Night Live, Ooli Show, Clip, Aired on 05/08/21" tabindex="-1" href="/saturday-night-live/video/ooli-show/4358913"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4358913"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Ooli Show</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/08/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="47" aria-label="Saturday Night Live, Murdur Durdur, Clip, Aired on 05/08/21" tabindex="-1" href="/saturday-night-live/video/murdur-durdur/4358914"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4358914"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Murdur Durdur</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/08/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="48" aria-label="Saturday Night Live, Elon Musk Promises to Behave on SNL, Clip, Aired on 05/06/21" tabindex="-1" href="/saturday-night-live/video/elon-musk-promises-to-behave-on-snl/4357481"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4357481"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Elon Musk Promises to Behave on SNL</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/06/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="49" aria-label="Saturday Night Live, Minnesota News Cold Open, Clip, Aired on 04/10/21" tabindex="-1" href="/saturday-night-live/video/minnesota-news-cold-open/4342364"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4342364"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Minnesota News Cold Open</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/10/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="50" aria-label="Saturday Night Live, Carey Mulligan Monologue, Clip, Aired on 04/10/21" tabindex="-1" href="/saturday-night-live/video/carey-mulligan-monologue/4342365"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4342365"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Carey Mulligan Monologue</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/10/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="51" aria-label="Saturday Night Live, Weekend Update: Matt Gaetz Venmo Sex Scandal, Clip, Aired on 04/10/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-matt-gaetz-venmo-sex-scandal/4342371"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4342371"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Matt Gaetz Venmo Sex Scandal</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/10/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="52" aria-label="Saturday Night Live, The War in Words: Bertie and Mary, Clip, Aired on 04/10/21" tabindex="-1" href="/saturday-night-live/video/the-war-in-words-bertie-and-mary/4342377"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4342377"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">The War in Words: Bertie and Mary</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/10/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="53" aria-label="Saturday Night Live, Lesbian Period Drama, Clip, Aired on 04/10/21" tabindex="-1" href="/saturday-night-live/video/lesbian-period-drama/4342367"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4342367"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Lesbian Period Drama</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/10/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="54" aria-label="Saturday Night Live, Star Trek Spinoff, Clip, Aired on 04/10/21" tabindex="-1" href="/saturday-night-live/video/star-trek-spinoff/4342376"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4342376"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Star Trek Spinoff</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/10/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="55" aria-label="Saturday Night Live, Weekend Update: New Dick’s Sporting Goods Store &amp; Taylor Swift Re-Records Album, Clip, Aired on 04/10/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-new-dicks-sporting-goods-store-taylor-swift-rerecords-album/4342373"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4342373"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: New Dick’s Sporting Goods Store &amp; Taylor Swift Re-Records Album</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/10/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="56" aria-label="Saturday Night Live, IBS Medicine Ad, Clip, Aired on 04/10/21" tabindex="-1" href="/saturday-night-live/video/ibs-medicine-ad/4342369"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4342369"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">IBS Medicine Ad</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/10/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="57" aria-label="Saturday Night Live, Weekend Update: The Iceberg on the Sinking of the Titanic, Clip, Aired on 04/10/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-the-iceberg-on-the-sinking-of-the-titanic/4342375"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4342375"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: The Iceberg on the Sinking of the Titanic</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/10/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="58" aria-label="Saturday Night Live, What’s Wrong with This Picture 2021, Clip, Aired on 04/10/21" tabindex="-1" href="/saturday-night-live/video/whats-wrong-with-this-picture-2021/4342366"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4342366"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">What’s Wrong with This Picture 2021</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/10/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="59" aria-label="Saturday Night Live, Weekend Update: Pineapple on the Paul Pierce Scandal, Clip, Aired on 04/10/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-pineapple-on-the-paul-pierce-scandal/4342374"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4342374"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Pineapple on the Paul Pierce Scandal</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/10/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="60" aria-label="Saturday Night Live, Study Buddy, Clip, Aired on 04/10/21" tabindex="-1" href="/saturday-night-live/video/study-buddy/4342368"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4342368"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Study Buddy</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/10/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="61" aria-label="Saturday Night Live, L’Eggs, Clip, Aired on 04/10/21" tabindex="-1" href="/saturday-night-live/video/leggs/4342380"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4342380"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">L’Eggs</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/10/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="62" aria-label="Saturday Night Live, Weird Little Flute ft. Kid Cudi, Clip, Aired on 04/10/21" tabindex="-1" href="/saturday-night-live/video/weird-little-flute-ft-kid-cudi/4342378"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4342378"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weird Little Flute ft. Kid Cudi</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/10/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="63" aria-label="Saturday Night Live, Weekend Update: Bruce Springsteen and Barack Obama on Their Podcast Renegades, Clip, Aired on 04/10/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-bruce-springsteen-and-barack-obama-on-their-podcast-renegades/4342372"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4342372"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Bruce Springsteen and Barack Obama on Their Podcast Renegades</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/10/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="64" aria-label="Saturday Night Live, Carey Mulligan Gets a New Nickname from Kenan Thompson, Clip, Aired on 04/08/21" tabindex="-1" href="/saturday-night-live/video/carey-mulligan-gets-a-new-nickname-from-kenan-thompson/4341395"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4341395"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Carey Mulligan Gets a New Nickname from Kenan Thompson</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/08/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="65" aria-label="Saturday Night Live, Britney Spears Talk Show Cold Open, Clip, Aired on 04/03/21" tabindex="-1" href="/saturday-night-live/video/britney-spears-talk-show-cold-open/4338727"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4338727"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Britney Spears Talk Show Cold Open</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/03/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="66" aria-label="Saturday Night Live, Frat Trip, Clip, Aired on 04/03/21" tabindex="-1" href="/saturday-night-live/video/frat-trip/4338744"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4338744"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Frat Trip</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/03/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="67" aria-label="Saturday Night Live, Viral Apology Video, Clip, Aired on 04/03/21" tabindex="-1" href="/saturday-night-live/video/viral-apology-video/4338745"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4338745"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Viral Apology Video</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/03/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="68" aria-label="Saturday Night Live, Weekend Update: Smokery Farm’s Easter Meats, Clip, Aired on 04/03/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-smokery-farms-easter-meats/4338738"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4338738"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Smokery Farm’s Easter Meats</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/03/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="69" aria-label="Saturday Night Live, The Hero, Clip, Aired on 04/03/21" tabindex="-1" href="/saturday-night-live/video/the-hero/4338735"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4338735"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">The Hero</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/03/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="70" aria-label="Saturday Night Live, Salt Bae, Clip, Aired on 04/03/21" tabindex="-1" href="/saturday-night-live/video/salt-bae/4338755"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4338755"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Salt Bae</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/03/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="71" aria-label="Saturday Night Live, Scattergories, Clip, Aired on 04/03/21" tabindex="-1" href="/saturday-night-live/video/scattergories/4338746"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4338746"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Scattergories</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/03/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="72" aria-label="Saturday Night Live, Beanie Babies, Clip, Aired on 04/03/21" tabindex="-1" href="/saturday-night-live/video/beanie-babies/4338748"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4338748"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Beanie Babies</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/03/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="73" aria-label="Saturday Night Live, Proud Parents, Clip, Aired on 04/03/21" tabindex="-1" href="/saturday-night-live/video/proud-parents/4338733"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4338733"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Proud Parents</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/03/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="74" aria-label="Saturday Night Live, Weekend Update: Guy Who Just Bought a Boat on Dating After Covid, Clip, Aired on 04/03/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-guy-who-just-bought-a-boat-on-dating-after-covid/4338741"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4338741"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Guy Who Just Bought a Boat on Dating After Covid</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/03/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="75" aria-label="Saturday Night Live, Half Brother, Clip, Aired on 04/03/21" tabindex="-1" href="/saturday-night-live/video/half-brother/4338742"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4338742"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Half Brother</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/03/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="76" aria-label="Saturday Night Live, Vaccine Game Show, Clip, Aired on 04/03/21" tabindex="-1" href="/saturday-night-live/video/vaccine-game-show/4338734"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4338734"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Vaccine Game Show</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/03/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="77" aria-label="Saturday Night Live, Weekend Update: Starbucks Turns 50, Naked Rock Climber, Clip, Aired on 04/03/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-starbucks-turns-50-naked-rock-climber/4338739"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4338739"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Starbucks Turns 50, Naked Rock Climber</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/03/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="78" aria-label="Saturday Night Live, Weekend Update: Matt Gaetz Under Investigation, Clip, Aired on 04/03/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-matt-gaetz-under-investigation/4338737"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4338737"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Matt Gaetz Under Investigation</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/03/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="79" aria-label="Saturday Night Live, Dog Park, Clip, Aired on 04/03/21" tabindex="-1" href="/saturday-night-live/video/dog-park/4338747"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4338747"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Dog Park</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/03/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="80" aria-label="Saturday Night Live, Daniel Kaluuya Monologue, Clip, Aired on 04/03/21" tabindex="-1" href="/saturday-night-live/video/daniel-kaluuya-monologue/4338728"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4338728"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Daniel Kaluuya Monologue</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/03/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="81" aria-label="Saturday Night Live, Weekend Update: Jeff and Hattie Deeley on Their Marriage, Clip, Aired on 04/03/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-jeff-and-hattie-deeley-on-their-marriage/4338740"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4338740"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Jeff and Hattie Deeley on Their Marriage</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/03/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="82" aria-label="Saturday Night Live, Daniel Kaluuya Says Put Down Your Book and Watch SNL, Clip, Aired on 04/01/21" tabindex="-1" href="/saturday-night-live/video/daniel-kaluuya-says-put-down-your-book-and-watch-snl/4337919"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4337919"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Daniel Kaluuya Says Put Down Your Book and Watch SNL</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>04/01/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="83" aria-label="Saturday Night Live, Daniel Kaluuya Is Hosting Saturday Night Live!, Clip, Aired on 03/30/21" tabindex="-1" href="/saturday-night-live/video/daniel-kaluuya-is-hosting-saturday-night-live/4335755"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4335755"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Daniel Kaluuya Is Hosting Saturday Night Live!</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>03/30/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="84" aria-label="Saturday Night Live, Snatched! Vaxed! or Waxed! Cold Open, Clip, Aired on 03/27/21" tabindex="-1" href="/saturday-night-live/video/snatched-vaxed-or-waxed-cold-open/4335178"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4335178"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Snatched! Vaxed! or Waxed! Cold Open</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>03/27/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="85" aria-label="Saturday Night Live, Maya Rudolph Monologue, Clip, Aired on 03/27/21" tabindex="-1" href="/saturday-night-live/video/maya-rudolph-monologue/4335179"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4335179"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Maya Rudolph Monologue</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>03/27/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="86" aria-label="Saturday Night Live, Weekend Update: Biden Calls for Gun Control, Clip, Aired on 03/27/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-biden-calls-for-gun-control/4335185"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4335185"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Biden Calls for Gun Control</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>03/27/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="87" aria-label="Saturday Night Live, Weekend Update: Bowen Yang on the Rise of Anti-Asian Hate Crimes, Clip, Aired on 03/27/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-bowen-yang-on-the-rise-of-antiasian-hate-crimes/4335188"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4335188"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Bowen Yang on the Rise of Anti-Asian Hate Crimes</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>03/27/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="88" aria-label="Saturday Night Live, NFTs, Clip, Aired on 03/27/21" tabindex="-1" href="/saturday-night-live/video/nfts/4335192"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4335192"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">NFTs</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>03/27/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="89" aria-label="Saturday Night Live, Hot Ones with Beyoncé, Clip, Aired on 03/27/21" tabindex="-1" href="/saturday-night-live/video/hot-ones-with-beyonce/4335182"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4335182"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Hot Ones with Beyoncé</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>03/27/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="90" aria-label="Saturday Night Live, Weekend Update: National Puppy Day and Black Muppets, Clip, Aired on 03/27/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-national-puppy-day-and-black-muppets/4335187"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4335187"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: National Puppy Day and Black Muppets</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>03/27/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="91" aria-label="Saturday Night Live, Weekend Update: Sidney Powell on Being Sued by Dominion, Clip, Aired on 03/27/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-sidney-powell-on-being-sued-by-dominion/4335186"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4335186"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Sidney Powell on Being Sued by Dominion</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>03/27/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="92" aria-label="Saturday Night Live, The Maya-ing, Clip, Aired on 03/27/21" tabindex="-1" href="/saturday-night-live/video/the-mayaing/4335189"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4335189"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">The Maya-ing</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>03/27/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="93" aria-label="Saturday Night Live, Boomers Got the Vax, Clip, Aired on 03/27/21" tabindex="-1" href="/saturday-night-live/video/boomers-got-the-vax/4335181"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4335181"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Boomers Got the Vax</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>03/27/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="94" aria-label="Saturday Night Live, Barfly Awards, Clip, Aired on 03/27/21" tabindex="-1" href="/saturday-night-live/video/barfly-awards/4335190"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4335190"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Barfly Awards</div><div class="tile__secondaryTitle"></div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>03/27/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li></ul></div><button type="button" class="shelf__arrow shelf__arrow--right" disabled="" aria-hidden="true"></button></div></section></div></div></section><section class="links-selectable-group"><div class="links-selectable-group__container"><div class="links-selectable-group__inner"><div class="filter-select"><button type="button" class="filter-select__inner" aria-haspopup="listbox" aria-labelledby="undefined undefined" aria-label="Season 46" aria-expanded="false"><span class="filter-select__selected">Season 46</span></button><ul class="filter-select__dropdown" role="listbox" tabindex="-1" aria-activedescendant="undefined-Season 46"><li class="filter-select__item" role="option" aria-selected="true" id="undefined-Season 46" tabindex="0"><span class="filter-select__link">Season 46</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 45" tabindex="0"><span class="filter-select__link">Season 45</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 44" tabindex="0"><span class="filter-select__link">Season 44</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 43" tabindex="0"><span class="filter-select__link">Season 43</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 42" tabindex="0"><span class="filter-select__link">Season 42</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 41" tabindex="0"><span class="filter-select__link">Season 41</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 40" tabindex="0"><span class="filter-select__link">Season 40</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 39" tabindex="0"><span class="filter-select__link">Season 39</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 38" tabindex="0"><span class="filter-select__link">Season 38</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 37" tabindex="0"><span class="filter-select__link">Season 37</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 36" tabindex="0"><span class="filter-select__link">Season 36</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 35" tabindex="0"><span class="filter-select__link">Season 35</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 34" tabindex="0"><span class="filter-select__link">Season 34</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 33" tabindex="0"><span class="filter-select__link">Season 33</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 32" tabindex="0"><span class="filter-select__link">Season 32</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 31" tabindex="0"><span class="filter-select__link">Season 31</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 30" tabindex="0"><span class="filter-select__link">Season 30</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 5" tabindex="0"><span class="filter-select__link">Season 5</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 4" tabindex="0"><span class="filter-select__link">Season 4</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 3" tabindex="0"><span class="filter-select__link">Season 3</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 2" tabindex="0"><span class="filter-select__link">Season 2</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 1" tabindex="0"><span class="filter-select__link">Season 1</span></li></ul></div><div class="lazy-component lazy-component--loading"><div class="spinner spinner--absolute spinner--light" theme="light" style="top:50%"><span style="animation-delay:-1.2s;transform:rotate(0deg) translate(146%)"></span><span style="animation-delay:-1.1s;transform:rotate(30deg) translate(146%)"></span><span style="animation-delay:-1s;transform:rotate(60deg) translate(146%)"></span><span style="animation-delay:-0.9s;transform:rotate(90deg) translate(146%)"></span><span style="animation-delay:-0.8s;transform:rotate(120deg) translate(146%)"></span><span style="animation-delay:-0.7s;transform:rotate(150deg) translate(146%)"></span><span style="animation-delay:-0.6s;transform:rotate(180deg) translate(146%)"></span><span style="animation-delay:-0.5s;transform:rotate(210deg) translate(146%)"></span><span style="animation-delay:-0.4s;transform:rotate(240deg) translate(146%)"></span><span style="animation-delay:-0.3s;transform:rotate(270deg) translate(146%)"></span><span style="animation-delay:-0.2s;transform:rotate(300deg) translate(146%)"></span><span style="animation-delay:-0.1s;transform:rotate(330deg) translate(146%)"></span></div></div></div></div></section></div></div></div><footer class="footer " role="contentinfo"><div class="footer__container"><div class="footer__logo"><a class="footer__logo__link footer__logo__link--nbc" href="/">NBC.com</a></div><section class="footer__top"><div><div class="footer__left"><div class="social-icons"><h2 class="social-icons__title">Share the Moment<span class="social-icons__trademark">™</span></h2><ul class="social-icons__icons"><li><a rel="noreferrer noopener" target="_blank" class="social-icons__icon--wrapper" name="facebook" role="link" title="Facebook" href="https://www.facebook.com/nbc"><span class="social-icons__icon facebook"></span></a></li><li><a rel="noreferrer noopener" target="_blank" class="social-icons__icon--wrapper" name="twitter" role="link" title="Twitter" href="https://twitter.com/nbc"><span class="social-icons__icon twitter"></span></a></li><li><a rel="noreferrer noopener" target="_blank" class="social-icons__icon--wrapper" name="tumblr" role="link" title="Tumblr" href="https://nbctv.tumblr.com"><span class="social-icons__icon tumblr"></span></a></li><li><a rel="noreferrer noopener" target="_blank" class="social-icons__icon--wrapper" name="pinterest" role="link" title="Pinterest" href="https://pinterest.com/nbctv"><span class="social-icons__icon pinterest"></span></a></li><li><a rel="noreferrer noopener" target="_blank" class="social-icons__icon--wrapper" name="youtube" role="link" title="YouTube" href="https://www.youtube.com/nbc"><span class="social-icons__icon youtube"></span></a></li></ul></div></div><div class="footer__right"><div class="quick-links"><h2 class="quick-links__title">NBC Quick Links</h2><ul class="quick-links__list"><li><a href="/mvpd-picker" target="">Link TV Provider</a></li><li><a target="_blank" rel="noreferrer noopener" href="">FAQ</a></li><li><a href="/global/pages/casting" target="">Casting</a></li><li><a target="_blank" rel="noreferrer noopener" href="">Contact Us</a></li><li><a href="/global/pages/tv-ratings" target="">Parental Guidelines and TV Ratings</a></li><li><a href="/tickets/pages/tickets-and-nbc-studio-tour" target="">Tickets and NBC Studio Tour</a></li><li><a href="/schedule" target="">Local Schedule</a></li></ul></div></div></div></section><div class="footer__legal"><div class="corporate-links"><ul class="corporate-links__list"><li><a href="/general/pages/accessibility" target="">Accessibility</a></li><li><a target="" rel="noreferrer noopener" href="http://www.nbcuni.com/">Corporate Info</a></li><li><a target="" rel="noreferrer noopener" href="http://www.nbcunicareers.com/">Jobs</a></li><li><a target="" rel="noreferrer noopener" href="https://www.nbcuniversal.com/privacy?intake=NBC_Entertainment">Privacy Policy</a></li><li><a href="/general/pages/terms" target="">Terms of Service</a></li><li><a href="/general/pages/advertise" target="">Advertise</a></li><li><a target="" rel="noreferrer noopener" href="http://nbc.researchresults.com/?s=657">Viewer Panel</a></li><li><a target="" rel="noreferrer noopener" href="https://www.nbcuniversal.com/privacy/california-consumer-privacy-act?intake=NBC_Entertainment">CA Notice</a></li><li><a href="/general/pages/closed-captioning" target="">Closed Captioning</a></li><li><a target="" rel="noreferrer noopener" href="https://www.nbcuniversal.com/privacy/notrtoo?intake=NBC_Entertainment">Do Not Sell My Personal Information</a></li><li><a href="/general/pages/vppa" target="">Video Viewing Policy</a></li><li><a target="" rel="noreferrer noopener" href="https://www.peacocktv.com/?cid=20200101evergreenoneedi002&amp;utm_source=nbc&amp;utm_medium=oneapp_editorial_footer_footerlink&amp;utm_campaign=20200101evergreen&amp;utm_term=weblink&amp;utm_content=footerlink">Peacock</a></li></ul></div></div></div><div class="footer__base"><ul class="footer__base__list"><li>A Division of <strong>NBCUniversal</strong></li><li><a href="https://www.nbcuniversal.com/privacy/cookies#accordionheader2" target="_blank" rel="noopener noreferrer">Ad Choices</a></li><li>©<!-- -->2021<!-- --> NBCUniversal Media, LLC</li></ul></div></footer><div class="responsive-app__cookies"><div class="responsive-app__cookies__wrapper"><div class="responsive-app__cookies__inner"><div class="responsive-app__cookies__text">We and our partners use cookies on this site to improve our service, perform analytics, personalize advertising, measure advertising performance, and remember website preferences. By using the site, you consent to these cookies. For more information on cookies including how to manage your consent visit our<!-- --> <a target="_blank" href="https://www.nbcuniversal.com/privacy/cookies" rel="noopener noreferrer">cookie policy</a>.</div><button class="button" type="button"><span><i></i>Continue</span></button></div></div></div></main></div></div>
        <script>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</script>
        <div id="scripts" data-reactroot=""><script src="/generetic/scripts/ads.js"></script><script src="https://entitlement.auth.adobe.com/entitlement/v4/AccessEnabler.js"></script><script src="https://pdk.theplatform.com/5.8.7/pdk/tpPdkController.js"></script><script src="//assets.adobedtm.com/a2ef59fba8e9/9c7a708dbcb2/launch-678397df18e0.min.js" async=""></script><script src="https://cdn.cookielaw.org/consent/ea571e64-7f5b-48d8-8d41-f96b1ddd4838/otSDKStub.js" crossorigin="anonymous" type="text/javascript" charset="UTF-8" data-domain-script="ea571e64-7f5b-48d8-8d41-f96b1ddd4838" integrity="sha384-MBKHs93r8p+/FKCTzkPhNxbLTPNVCDEZC9KBNEN/gkg+JepD6JUJXYf7VQHn9qmj" async=""></script></div>
        <script async src=/generetic/generated/chunks/49.daab4515db71b9d1c9b9.js></script>
<script async src=/generetic/generated/generetic.58d32494dd967e443a10.js></script>
<script async src=/generetic/generated/chunks/0.1a3d19e45973dcdc73d8.js></script>
<script async src=/generetic/generated/chunks/1.36554331d0745b8b6c7d.js></script>
<script async src=/generetic/generated/chunks/10.9fb03abd5c59f1eb46d6.js></script>
<script async src=/generetic/generated/chunks/2.e16593e99498ef344128.js></script>
<script async src=/generetic/generated/chunks/44.8a959bd0f205431b28c8.js></script>
      </body>
    </html>