<!DOCTYPE html><html lang="en-US" class="responsive">
      <head>
        
          <script type="text/javascript" data-platform="web" data-params='{"name":"saturday-night-live/video/oprah/2749702","type":"VIDEO"}'>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</script>
        
        <link rel="preload" as="style" href="/generetic/generated/49.generetic.5563142fc412679850a3.css" />
<link rel="preload" as="script" href="/generetic/generated/chunks/49.a89bfc9347d14ee84412.js" />
<link rel="preload" as="style" href="/generetic/generated/generetic.946da2747c41991fb36d.css" />
<link rel="preload" as="script" href="/generetic/generated/generetic.d5b2ea14d1f912c615fc.js" />
<link rel="preload" as="script" href="/generetic/generated/chunks/0.9a3cdf05c3fd4562d8cd.js" />
<link rel="preload" as="script" href="/generetic/generated/chunks/1.c2ae86ca7dbf30d7ee12.js" />
<link rel="preload" as="script" href="/generetic/generated/chunks/11.e5794a4e3d1f3652324a.js" />
<link rel="preload" as="script" href="/generetic/generated/chunks/2.7c5fcc55ad4712c4190c.js" />
<link rel="preload" as="script" href="/generetic/generated/chunks/45.615a1752edad80af5b2a.js" />
        <link rel="stylesheet" href=/generetic/generated/49.generetic.5563142fc412679850a3.css />
<link rel="stylesheet" href=/generetic/generated/generetic.946da2747c41991fb36d.css />
        <link rel="preload" as="font" href="/generetic/generated/fonts/SourceSansProRegular.woff2" type="font/woff2" crossorigin />
<link rel="preload" as="font" href="/generetic/generated/fonts/SourceSansProSemiBold.woff2" type="font/woff2" crossorigin />
<link rel="preload" as="font" href="/generetic/generated/fonts/SourceSansProLight.woff2" type="font/woff2" crossorigin />
<link rel="preload" as="font" href="/generetic/generated/fonts/MontserratRegular.woff2" type="font/woff2" crossorigin />
<link rel="preload" as="font" href="/generetic/generated/fonts/MontserratBold.woff2" type="font/woff2" crossorigin />
        <title data-reactroot="">Watch Saturday Night Live Highlight: Oprah - NBC.com</title><meta name="description" content="Watch Saturday Night Live highlight &#x27;Oprah&#x27; on NBC.com" data-reactroot=""/><meta property="og:type" content="video.other" data-reactroot=""/><meta property="og:title" content="Watch Saturday Night Live Highlight: Oprah - NBC.com" data-reactroot=""/><meta property="og:description" content="Watch Saturday Night Live highlight &#x27;Oprah&#x27; on NBC.com" data-reactroot=""/><meta property="og:image" content="https://img.nbc.com/sites/nbcunbc/files/images/2015/3/18/140228_2749702_Oprah_anvver_2.jpg" data-reactroot=""/><meta property="og:image:type" content="image/jpeg" data-reactroot=""/><meta property="og:image:width" content="640" data-reactroot=""/><meta property="og:image:height" content="360" data-reactroot=""/><meta name="twitter:title" content="Watch Saturday Night Live Highlight: Oprah - NBC.com" data-reactroot=""/><meta name="twitter:image" content="https://img.nbc.com/sites/nbcunbc/files/images/2015/3/18/140228_2749702_Oprah_anvver_2.jpg" data-reactroot=""/><meta name="twitter:card" content="app" data-reactroot=""/><meta name="twitter:description" content="Watch Saturday Night Live highlight &#x27;Oprah&#x27; on NBC.com" data-reactroot=""/><meta name="twitter:app:url:iphone" content="nbctve://video/2749702" data-reactroot=""/><meta name="twitter:app:url:ipad" content="nbctve://video/2749702" data-reactroot=""/><meta name="twitter:app:url:googleplay" content="nbctve://video/2749702" data-reactroot=""/><link rel="canonical" href="https://www.nbc.com/saturday-night-live/video/oprah/2749702" data-reactroot=""/><meta property="og:video" content="https://pdk.theplatform.com/current/pdk/swf/flvPlayer.swf?id=player&amp;v=%2F%2Fplayer.theplatform.com%2Fp%2FNnzsPC%2Fwidget%2Fconfig%2Fselect%2Fmedia%2Fguid%2F2410887629%2F2749702%3Ffwsitesection%3Dnbc_video_vod_embed%26form%3Dvars%26component%3Dplayer%26autoPlay%3Dtrue%26referrer%3Dfacebook" data-reactroot=""/><meta property="og:video:secure_url" content="https://pdk.theplatform.com/current/pdk/swf/flvPlayer.swf?id=player&amp;v=%2F%2Fplayer.theplatform.com%2Fp%2FNnzsPC%2Fwidget%2Fconfig%2Fselect%2Fmedia%2Fguid%2F2410887629%2F2749702%3Ffwsitesection%3Dnbc_video_vod_embed%26form%3Dvars%26component%3Dplayer%26autoPlay%3Dtrue%26referrer%3Dfacebook" data-reactroot=""/><meta property="video:actor" content="Tim Meadows" data-reactroot=""/><meta property="video:duration" content="276" data-reactroot=""/><meta property="video:series" content="Saturday Night Live" data-reactroot=""/><meta property="video:tag" content="Clip" data-reactroot=""/><meta property="video:release_date" content="1998-03-01" data-reactroot=""/><script type="application/ld+json" data-reactroot="">{"@context":"https://schema.org","@id":"2749702","@type":"TVClip","name":"Oprah","description":"After enjoying a tasty burger, Oprah interviews Monica Lewinsky about her oral sex allegations.","video":{"@type":"VideoObject","name":"Oprah","description":"After enjoying a tasty burger, Oprah interviews Monica Lewinsky about her oral sex allegations.","embedURL":"//player.theplatform.com/p/NnzsPC/widget/config/select/media/guid/2410887629/2749702?fwsitesection=nbc_video_vod_embed","uploadDate":"1998-03-01T07:30:00.000Z","thumbnailUrl":"https://img.nbc.com/sites/nbcunbc/files/images/2015/3/18/140228_2749702_Oprah_anvver_2.jpg","potentialAction":[{"@type":"WatchAction","target":{"@type":"EntryPoint","inLanguage":"EN","urlTemplate":"/saturday-night-live/video/oprah/2749702","actionPlatform":"http://schema.org/DesktopWebPlatform"},"expectsAcceptanceOf":[{"@type":"Offer","category":"free","eligibleRegion":[{"@type":"Country","name":"GU"},{"@type":"Country","name":"MP"},{"@type":"Country","name":"PR"},{"@type":"Country","name":"US"},{"@type":"Country","name":"VI"}]}]},{"@type":"WatchAction","target":{"@type":"EntryPoint","inLanguage":"EN","urlTemplate":"/saturday-night-live/video/oprah/2749702","actionPlatform":"http://schema.org/MobileWebPlatform"},"expectsAcceptanceOf":[{"@type":"Offer","category":"free","eligibleRegion":[{"@type":"Country","name":"GU"},{"@type":"Country","name":"MP"},{"@type":"Country","name":"PR"},{"@type":"Country","name":"US"},{"@type":"Country","name":"VI"}]}]}],"url":"/saturday-night-live/video/oprah/2749702"},"partOfSeries":{"@type":"TVSeries","name":"Saturday Night Live","sameAs":"https://www.imdb.com/title/tt0072562/","url":"https://www.nbc.com/saturday-night-live","description":"Saturdays at 11:30 p.m., live coast-to-coast. NBC's Emmy-winning late-night comedy showcase enters its 45th season."},"partOfSeason":{"@type":"TVSeason","seasonNumber":"23"}}</script><meta charset="utf-8" data-reactroot=""/><meta name="viewport" content="width=device-width, initial-scale=1" data-reactroot=""/><meta name="apple-media-service-subscription" content="expires=9999, type=free" data-reactroot=""/><meta property="fb:app_id" content="653521154659171" data-reactroot=""/><meta property="og:site_name" content="NBC" data-reactroot=""/><meta property="og:url" content="https://www.nbc.com/saturday-night-live/video/oprah/2749702" data-reactroot=""/><meta property="al:android:package" content="com.nbcuni.nbc" data-reactroot=""/><meta property="al:android:app_name" content="NBC" data-reactroot=""/><meta property="al:ios:app_store_id" content="442839435" data-reactroot=""/><meta property="al:ios:app_name" content="NBC" data-reactroot=""/><meta property="al:ipad:app_store_id" content="442839435" data-reactroot=""/><meta property="al:ipad:app_name" content="NBC" data-reactroot=""/><meta property="al:iphone:app_store_id" content="442839435" data-reactroot=""/><meta property="al:iphone:app_name" content="NBC" data-reactroot=""/><meta property="al:web:url" content="https://www.nbc.com/saturday-night-live/video/oprah/2749702" data-reactroot=""/><meta property="al:web:should_fallback" content="true" data-reactroot=""/><meta name="twitter:site" content="@nbc" data-reactroot=""/><meta name="twitter:site:id" content="26585095" data-reactroot=""/><meta name="twitter:url" content="https://www.nbc.com/saturday-night-live/video/oprah/2749702" data-reactroot=""/><meta name="twitter:app:country" content="US" data-reactroot=""/><meta name="twitter:app:name:iphone" content="NBC" data-reactroot=""/><meta name="twitter:app:id:iphone" content="442839435" data-reactroot=""/><meta name="twitter:app:name:ipad" content="NBC" data-reactroot=""/><meta name="twitter:app:id:ipad" content="442839435" data-reactroot=""/><meta name="twitter:app:name:googleplay" content="NBC" data-reactroot=""/><meta name="twitter:app:id:googleplay" content="com.nbcuni.nbc" data-reactroot=""/><meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" data-reactroot=""/><link rel="alternate" href="https://www.nbc.com/saturday-night-live/video/oprah/2749702" hrefLang="en" data-reactroot=""/><link rel="alternate" href="https://www.nbc.com/saturday-night-live/video/oprah/2749702?lang=es" hrefLang="es" data-reactroot=""/><link rel="shortcut icon" href="/generetic/favicon.ico" type="image/x-icon" data-reactroot=""/><link rel="icon" href="/generetic/favicon.ico" type="image/x-icon" data-reactroot=""/><link rel="apple-touch-icon" href="/generetic/images/apple-touch-icon.png" data-reactroot=""/>
        <link rel="preconnect" href="https://identity.mparticle.com">
        <link rel="preconnect" href="https://friendship.nbc.co">
        <link rel="dns-prefetch" href="https://identity.mparticle.com">
        <link rel="dns-prefetch" href="https://friendship.nbc.co">
        <link rel="dns-prefetch" href="https://static.vilynx.com">
        <link rel="dns-prefetch" href="https://public.vilynx.com">
      
                              <script>!function(a){var e="https://s.go-mpulse.net/boomerang/",t="addEventListener";if("False"=="True")a.BOOMR_config=a.BOOMR_config||{},a.BOOMR_config.PageParams=a.BOOMR_config.PageParams||{},a.BOOMR_config.PageParams.pci=!0,e="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="P9G88-GQ2QU-M824B-4WKRW-LBG3T",function(){function n(e){a.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!a.BOOMR||!a.BOOMR.version&&!a.BOOMR.snippetExecuted){a.BOOMR=a.BOOMR||{},a.BOOMR.snippetExecuted=!0;var i,_,o,r=document.createElement("iframe");if(a[t])a[t]("load",n,!1);else if(a.attachEvent)a.attachEvent("onload",n);r.src="javascript:void(0)",r.title="",r.role="presentation",(r.frameElement||r).style.cssText="width:0;height:0;border:0;display:none;",o=document.getElementsByTagName("script")[0],o.parentNode.insertBefore(r,o);try{_=r.contentWindow.document}catch(O){i=document.domain,r.src="javascript:var d=document.open();d.domain='"+i+"';void(0);",_=r.contentWindow.document}_.open()._l=function(){var a=this.createElement("script");if(i)this.domain=i;a.id="boomr-if-as",a.src=e+"P9G88-GQ2QU-M824B-4WKRW-LBG3T",BOOMR_lstart=(new Date).getTime(),this.body.appendChild(a)},_.write("<bo"+'dy onload="document._l();">'),_.close()}}(),"".length>0)if(a&&"performance"in a&&a.performance&&"function"==typeof a.performance.setResourceTimingBufferSize)a.performance.setResourceTimingBufferSize();!function(){if(BOOMR=a.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var e=""=="true"?1:0,t="",n="nml5ubax3suh2yljxafq-f-52453bad4-clientnsv4-s.akamaihd.net",i="false"=="true"?2:1,_={"ak.v":"32","ak.cp":"260350","ak.ai":parseInt("157040",10),"ak.ol":"0","ak.cr":1,"ak.ipv":4,"ak.proto":"http/1.1","ak.rid":"405e8f94","ak.r":34485,"ak.a2":e,"ak.m":"dscb","ak.n":"essl","ak.bpcip":"107.23.218.0","ak.cport":36586,"ak.gh":"104.76.198.143","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"reno","ak.t":"1634318347","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==nWTf6tGuAAYVZnJz+Ak3JA/N2XEM9I9Fxealuy2oQDlVn8qYnB6Aow05YiOTIjlJuDrT07AsXjoTuCRQQe6dmBEpl6ktg9bYs9Ci5UGFdaPZkWGLURSiPVOGFGTZmsAS4APEmHOjrbzHjU0YUhtyisXdFpOvqRcpJeD9q12OXyxbYa3lruJH/Mrlyk+tLppXTrfa00WSxr8eA2YRm4BPCJgmM2ZHGjMkxJ8ayg+x+orVCJet01rJhQ7xlQvTKq3x02RZxEX1CVUHPPEvARDHeBR62+2CFX3uFBOgzfbRst0IyF6t6Rlu0XQYw1xFgxetwsjrvqiIyPi8eC5JOxtNBSh28J2VDM2TKGqYV2MQSLik9YU+BPrHN7vXy8aQKm/1iaOwP71SFQfzr2rr3CwX9QfOk2DGdugaEPq7+bvKHkI=","ak.pv":"442","ak.dpoabenc":"","ak.tf":i};if(""!==t)_["ak.ruds"]=t;var o={i:!1,av:function(e){var t="http.initiator";if(e&&(!e[t]||"spa_hard"===e[t]))_["ak.feo"]=void 0!==a.aFeoApplied?1:0,BOOMR.addVar(_)},rv:function(){var a=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t","ak.tf"];BOOMR.removeVar(a)}};BOOMR.plugins.AK={akVars:_,akDNSPreFetchDomain:n,init:function(){if(!o.i){var a=BOOMR.subscribe;a("before_beacon",o.av,null,null),a("onbeacon",o.rv,null,null),o.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head>
      <body>
        <div id="app"><div class="responsive-app" data-reactroot=""><header class="responsive-app__header"><nav role="navigation" class="navigation navigation--sticky navigation--show-page"><div class="navigation__inner navigation__inner--show-page"><div class="navigation__logo-wrapper navigation__logo-wrapper--show-page"><div class="navigation__item navigation__item--accessibility navigation__item--hidden"><a href="#main-content" class="navigation__accessibility-button"><span>Skip to Content</span></a></div><a class="navigation__logo navigation__logo--nbc" href="/">NBC.com</a><div class="navigation__mobile--wrapper"><button type="button" class="navigation__search navigation__search--mobile" aria-label="Toggle site search"><span></span></button><button type="button" class="navigation__hamburger" aria-label="Toggle main navigation"></button></div></div><ul class="navigation__list navigation__list--nbc navigation__list--show-page"><li class="navigation__item navigation__item--nbc-label"><span class="navigation__item__title">NBC.com</span></li><li class="navigation__item navigation__item--home"><a class="navigation__item__link" href="/"><span class="navigation__item__title">Home</span></a></li><li class="navigation__item navigation__item--shows"><a class="navigation__item__link" href="/shows/all/popular"><span class="navigation__item__title navigation__item__title--no-transform">Shows</span></a></li><li class="navigation__item navigation__item--movies"><a class="navigation__item__link" href="/movies/popular"><span class="navigation__item__title navigation__item__title--no-transform">Movies</span></a></li><li class="navigation__item"><a class="navigation__item__link" href="/networks"><span class="navigation__item__title">Networks</span></a></li><li class="navigation__item navigation__item--live"><a class="navigation__item__link" href="/live"><span class="navigation__item__title">Live</span></a></li><li class="navigation__item"><a class="navigation__item__link" href="/apps?brand=nbc"><span class="navigation__item__title">App</span></a></li><li class="navigation__item"><a class="navigation__item__link" href="https://www.nbcstore.com/?cid=nbc_global_nav_shop"><span class="navigation__item__title">Shop</span></a></li><li class="navigation__item navigation__item--search"><button type="button" class="navigation__search navigation__item__title" aria-label="Toggle site search"><span></span></button></li><div class="navigation__identity--block"><li class="navigation__item navigation__item--identity"><div class="navigation__item__spinner"><div class="spinner spinner--relative spinner--small spinner--light" theme="light" style="top:19px"><span style="animation-delay:-1.2s;transform:rotate(0deg) translate(146%)"></span><span style="animation-delay:-1.1s;transform:rotate(30deg) translate(146%)"></span><span style="animation-delay:-1s;transform:rotate(60deg) translate(146%)"></span><span style="animation-delay:-0.9s;transform:rotate(90deg) translate(146%)"></span><span style="animation-delay:-0.8s;transform:rotate(120deg) translate(146%)"></span><span style="animation-delay:-0.7s;transform:rotate(150deg) translate(146%)"></span><span style="animation-delay:-0.6s;transform:rotate(180deg) translate(146%)"></span><span style="animation-delay:-0.5s;transform:rotate(210deg) translate(146%)"></span><span style="animation-delay:-0.4s;transform:rotate(240deg) translate(146%)"></span><span style="animation-delay:-0.3s;transform:rotate(270deg) translate(146%)"></span><span style="animation-delay:-0.2s;transform:rotate(300deg) translate(146%)"></span><span style="animation-delay:-0.1s;transform:rotate(330deg) translate(146%)"></span></div></div></li></div></ul></div></nav></header><div id="contentAccessEnabler"></div><main id="main" role="main" class="responsive-app__main"><div class="screen-reader"><p tabindex="-1" id="main-content">Main Content</p></div><div class="responsive-app__wrapper responsive-app__wrapper--nbc"><div class="video-page"><div class="video-page__sections"><div class="sticky-outer-wrapper show-header show-header--animate"><div class="sticky-inner-wrapper" style="position:relative;top:0px"><div class="show-header__background" style="background-image:linear-gradient(95deg, #155a92, #232b40)"><div class="show-header__info"><div class="show-header__title"><span class="show-header__title__inner">Saturday Night Live</span></div><div class="show-header__tune-in">SATURDAYS | 11:30ET 10:30CT 9:30MT 8:30PT</div></div></div></div></div><div class="sticky-outer-wrapper show-navigation show-header--animate"><div class="sticky-inner-wrapper" style="position:relative;top:0px"><div class="show-header__menu"><ul class="show-header__list"><li class="navigation__item__favorites-link"><button class="navigation__item__link" aria-label="Add To Favorites" data-tip="Added to Favorites" role="tab" tabindex="0" data-interaction="add" type="button"><span><i class="show-header__add-favorite-icon"></i></span></button></li><div class="show-header__list--scrollable"><div class="show-header__list--scrollable-inner" style="transform:translateX(0px)"><li class="navigation__item__link navigation__item__link--div" style="color:#155a92" data-index="0"><a class="navigation__item__link navigation__item__link_target" href="/saturday-night-live" target="" aria-label="Watch" role="tab" data-index="0"><span>watch</span></a></li><li class="navigation__item__link navigation__item__link--div" style="color:#155a92" data-index="1"><a class="navigation__item__link navigation__item__link_target" href="/saturday-night-live/about" target="" aria-label="About" role="tab" data-index="1"><span>about</span></a></li><li class="navigation__item__link navigation__item__link--div" style="color:#155a92" data-index="2"><a class="navigation__item__link navigation__item__link_target" href="/saturday-night-live/episodes" target="" aria-label="Episodes" role="tab" data-index="2"><span>episodes</span></a></li><li class="navigation__item__link navigation__item__link--div" style="color:#155a92" data-index="3"><a class="navigation__item__link navigation__item__link_target" href="/saturday-night-live/photos" target="" aria-label="Photos" role="tab" data-index="3"><span>photos</span></a></li><li class="navigation__item__link navigation__item__link--div" style="color:#155a92" data-index="4"><a class="navigation__item__link navigation__item__link_target" href="/saturday-night-live/credits/cast" target="" aria-label="Cast" role="tab" data-index="4"><span>cast</span></a></li><li class="navigation__item__link navigation__item__link--div" style="color:#155a92" data-index="5"><a target="_blank" rel="noreferrer noopener" class="navigation__item__link navigation__item__link_target" href="https://www.nbcstore.com/shop-by-show/saturday-night-live.html#utm_source=NBC&amp;utm_medium=Banner&amp;utm_campaign=saturday-night-live" aria-label="Shop" role="tab" data-index="5"><span>shop</span></a></li><li class="navigation__item__link navigation__item__link--div" style="color:#155a92" data-index="6"><a target="_blank" rel="noreferrer noopener" class="navigation__item__link navigation__item__link_target" href="https://www.peacocktv.com/stream-tv/saturday-night-live?cid=2110snlsimoaownseolk4100&amp;utm_campaign=2110snlsim&amp;utm_source=oanbc_nbc_st-sv&amp;utm_medium=own_seolk_navlnk&amp;utm_term=snlshowpgvisitor&amp;utm_content=snlpgnav" aria-label="SNL on Peacock" role="tab" data-index="6"><span>snl on peacock</span></a></li></div></div></ul><div class="show-header__menu__arrows"><button type="button" aria-label="Go to left" disabled="" class="show-header__menu__arrow show-header__menu__arrow--disabled"><span class="show-header__menu__arrow show-header__menu__arrow--left"></span></button><button type="button" aria-label="Go to right" class="show-header__menu__arrow"><span class="show-header__menu__arrow show-header__menu__arrow--right"></span></button></div></div><div class="__react_component_tooltip place-bottom type-dark" data-id="tooltip"></div></div></div><section class="video-page__player video-page__player--isZoomable"><div class="video-page__player--inner"><div class="video-page__spinner"><div class="video-page__spinner__wrapper"><div class="spinner spinner--relative spinner--light" theme="light" style="top:50%"><span style="animation-delay:-1.2s;transform:rotate(0deg) translate(146%)"></span><span style="animation-delay:-1.1s;transform:rotate(30deg) translate(146%)"></span><span style="animation-delay:-1s;transform:rotate(60deg) translate(146%)"></span><span style="animation-delay:-0.9s;transform:rotate(90deg) translate(146%)"></span><span style="animation-delay:-0.8s;transform:rotate(120deg) translate(146%)"></span><span style="animation-delay:-0.7s;transform:rotate(150deg) translate(146%)"></span><span style="animation-delay:-0.6s;transform:rotate(180deg) translate(146%)"></span><span style="animation-delay:-0.5s;transform:rotate(210deg) translate(146%)"></span><span style="animation-delay:-0.4s;transform:rotate(240deg) translate(146%)"></span><span style="animation-delay:-0.3s;transform:rotate(270deg) translate(146%)"></span><span style="animation-delay:-0.2s;transform:rotate(300deg) translate(146%)"></span><span style="animation-delay:-0.1s;transform:rotate(330deg) translate(146%)"></span></div></div></div></div></section><div class="video-meta"><div class="video-meta__container"><div class="video-meta__inner"><h1 class="video-meta__title"><span>Oprah</span></h1><div class="video-meta__secondary-title"><span class="video-meta__badge">CLIP</span><span>02/28/98</span></div><div class="video-meta__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div><button type="button" class="video-meta__expand"><span class="video-meta__expand__text" style="background-color:#155a92">Details</span></button></div></div></div><div class="video-meta__expandable"><div class="video-meta__details-container"><div class="video-meta__details"><a class="video-meta__app-link" href="/apps" tabindex="-1"><span class="video-meta__app-link__text">Also available on the <!-- -->nbc<!-- --> app</span></a><p class="video-meta__description">After enjoying a tasty burger, Oprah interviews Monica Lewinsky about her oral sex allegations.</p><div class="video-meta__appearing"><span class="video-meta__appearing-title">Appearing:</span><span class="video-meta__appearing-credit">Tim Meadows</span></div><div class="video-meta__tags">Tags: 1990, Oprah Monica Lewinsky, Oprah burger, Monica Lewinsky talk show, Oprah Winfrey eating, Lewinsky book, &quot;Mouth love&quot;</div><div class="video-meta__info"><span class="video-meta__episode">S23 E14</span><span class="video-meta__length">5 min</span><span class="video-meta__type">Highlight</span><span class="video-meta__show-type">Comedy</span><span class="video-meta__show-air-type">Late Night</span></div><div class="video-meta__copyright">-</div><div class="share"><a class="share__btn share__btn--facebook" aria-label="Share on Facebook" rel="noreferrer noopener" target="_blank" title="Facebook" href="https://www.facebook.com/sharer/sharer.php?u=" tabindex="-1"></a><a class="share__btn share__btn--twitter" aria-label="Share on Twitter" rel="noreferrer noopener" target="_blank" title="Twitter" href="https://twitter.com/intent/tweet?text=Watch%2002%2F28%2F98%20from%20Saturday%20Night%20Live%20on%20NBC.com&amp;url=" tabindex="-1"></a></div></div></div></div><section class="links-selectable-group"><div class="links-selectable-group__container"><div class="links-selectable-group__inner"><div class="filter-select"><button type="button" class="filter-select__inner" aria-haspopup="listbox" aria-labelledby="undefined undefined" aria-label="Most Recent" aria-expanded="false"><span class="filter-select__selected">Most Recent</span></button><ul class="filter-select__dropdown" role="listbox" tabindex="-1" aria-activedescendant="undefined-Most Recent"><li class="filter-select__item" role="option" aria-selected="true" id="undefined-Most Recent" tabindex="0"><span class="filter-select__link">Most Recent</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Behind the Scenes" tabindex="0"><span class="filter-select__link">Behind the Scenes</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Current Preview" tabindex="0"><span class="filter-select__link">Current Preview</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Excerpt" tabindex="0"><span class="filter-select__link">Excerpt</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Highlight" tabindex="0"><span class="filter-select__link">Highlight</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Sneak Peek" tabindex="0"><span class="filter-select__link">Sneak Peek</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Web Exclusive" tabindex="0"><span class="filter-select__link">Web Exclusive</span></li></ul></div><section class="shelf shelf--default shelf--ClipTile"><div class="section-heading section-heading--text"><h2 class="section-heading__title" id="section-heading-clips">Clips</h2></div><div class="shelf__inner"><button type="button" class="shelf__arrow shelf__arrow--left" disabled="" aria-hidden="true"></button><div class="shelf__tiles"><ul class="shelf__tiles__inner" style="transform:translate3d(0px, 0, 0)" aria-labelledby="section-heading-clips"><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="0" aria-label="Saturday Night Live, SNL Host Rami Malek and Ego Nwodim Have a Staring Contest, Clip, Aired on 10/14/21" href="/saturday-night-live/video/snl-host-rami-malek-and-ego-nwodim-have-a-staring-contest/589701854"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="589701854"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">SNL Host Rami Malek and Ego Nwodim Have a Staring Contest</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/14/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="1" aria-label="Saturday Night Live, Rami Malek Is Hosting SNL!, Clip, Aired on 10/11/21" tabindex="-1" href="/saturday-night-live/video/rami-malek-is-hosting-snl/257925718"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="257925718"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Rami Malek Is Hosting SNL!</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/11/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="2" aria-label="Saturday Night Live, Facebook Hearings Cold Open, Clip, Aired on 10/09/21" tabindex="-1" href="/saturday-night-live/video/facebook-hearings-cold-open/179589859"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="179589859"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Facebook Hearings Cold Open</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/09/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="3" aria-label="Saturday Night Live, Kim Kardashian West Monologue, Clip, Aired on 10/09/21" tabindex="-1" href="/saturday-night-live/video/kim-kardashian-west-monologue/179077767"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="179077767"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Kim Kardashian West Monologue</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/09/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="4" aria-label="Saturday Night Live, The Dream Guy, Clip, Aired on 10/09/21" tabindex="-1" href="/saturday-night-live/video/the-dream-guy/180613724"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="180613724"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">The Dream Guy</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/09/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="5" aria-label="Saturday Night Live, Weekend Update: Facebook Under Fire, Clip, Aired on 10/09/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-facebook-under-fire/180613720"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="180613720"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Facebook Under Fire</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/09/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="6" aria-label="Saturday Night Live, Jasmine and Aladdin, Clip, Aired on 10/09/21" tabindex="-1" href="/saturday-night-live/video/jasmine-and-aladdin/180101824"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="180101824"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Jasmine and Aladdin</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/09/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="7" aria-label="Saturday Night Live, Lotto Drawing, Clip, Aired on 10/09/21" tabindex="-1" href="/saturday-night-live/video/lotto-drawing/180101833"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="180101833"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Lotto Drawing</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/09/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="8" aria-label="Saturday Night Live, Costco Meeting, Clip, Aired on 10/09/21" tabindex="-1" href="/saturday-night-live/video/costco-meeting/180613719"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="180613719"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Costco Meeting</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/09/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="9" aria-label="Saturday Night Live, Skims Commercial, Clip, Aired on 10/09/21" tabindex="-1" href="/saturday-night-live/video/skims-commercial/180101832"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="180101832"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Skims Commercial</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/09/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="10" aria-label="Saturday Night Live, The People&#x27;s Kourt, Clip, Aired on 10/09/21" tabindex="-1" href="/saturday-night-live/video/the-peoples-kourt/179589861"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="179589861"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">The People&#x27;s Kourt</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/09/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="11" aria-label="Saturday Night Live, Weekend Update: Life Coach Kelly Party on Positive Thinking, Clip, Aired on 10/09/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-life-coach-kelly-party-on-positive-thinking/180101828"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="180101828"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Life Coach Kelly Party on Positive Thinking</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/09/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="12" aria-label="Saturday Night Live, Halsey: I Am Not a Woman, I&#x27;m a God (Live), Clip, Aired on 10/09/21" tabindex="-1" href="/saturday-night-live/video/halsey-i-am-not-a-woman-im-a-god-live/179077769"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="179077769"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Halsey: I Am Not a Woman, I&#x27;m a God (Live)</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/09/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="13" aria-label="Saturday Night Live, The Switch, Clip, Aired on 10/09/21" tabindex="-1" href="/saturday-night-live/video/the-switch/180101829"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="180101829"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">The Switch</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/09/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="14" aria-label="Saturday Night Live, Weekend Update: Terry Fink’s Fall 2021 Movie Review, Clip, Aired on 10/09/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-terry-finks-fall-2021-movie-review/179589860"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="179589860"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Terry Fink’s Fall 2021 Movie Review</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/09/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="15" aria-label="Saturday Night Live, Halsey ft. Lindsey Buckingham: Darling (Live), Clip, Aired on 10/09/21" tabindex="-1" href="/saturday-night-live/video/halsey-ft-lindsey-buckingham-darling-live/180613725"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="180613725"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Halsey ft. Lindsey Buckingham: Darling (Live)</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/09/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="16" aria-label="Saturday Night Live, Weekend Update: Harry Styles Reveals Song Meaning, Clint Eastwood CBD Lawsuit, Clip, Aired on 10/09/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-harry-styles-reveals-song-meaning-clint-eastwood-cbd-lawsuit/180613722"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="180613722"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Harry Styles Reveals Song Meaning, Clint Eastwood CBD Lawsuit</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/09/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="17" aria-label="Saturday Night Live, Ladies Night Song, Clip, Aired on 10/09/21" tabindex="-1" href="/saturday-night-live/video/ladies-night-song/179077768"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="179077768"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Ladies Night Song</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/09/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="18" aria-label="Saturday Night Live, Please Don&#x27;t Destroy – Hard Seltzer, Clip, Aired on 10/09/21" tabindex="-1" href="/saturday-night-live/video/please-dont-destroy-hard-seltzer/179077770"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="179077770"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Please Don&#x27;t Destroy – Hard Seltzer</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/09/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="19" aria-label="Saturday Night Live, Kim Kardashian West Isn’t Nervous About Hosting SNL, Clip, Aired on 10/07/21" tabindex="-1" href="/saturday-night-live/video/kim-kardashian-west-isnt-nervous-about-hosting-snl/140325638"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="140325638"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Kim Kardashian West Isn’t Nervous About Hosting SNL</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/07/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="20" aria-label="Saturday Night Live, Biden Unites Democrats Cold Open, Clip, Aired on 10/02/21" tabindex="-1" href="/saturday-night-live/video/biden-unites-democrats-cold-open/607685692"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="607685692"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Biden Unites Democrats Cold Open</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/02/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="21" aria-label="Saturday Night Live, Owen Wilson Monologue, Clip, Aired on 10/02/21" tabindex="-1" href="/saturday-night-live/video/owen-wilson-monologue/607173626"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="607173626"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Owen Wilson Monologue</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/02/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="22" aria-label="Saturday Night Live, Weekend Update: Democrats Delay Infrastructure Vote, R. Kelly Found Guilty, Clip, Aired on 10/02/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-democrats-delay-infrastructure-vote-r-kelly-found-guilty/607173629"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="607173629"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Democrats Delay Infrastructure Vote, R. Kelly Found Guilty</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/02/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="23" aria-label="Saturday Night Live, Weekend Update: Pete Davidson on the Met Gala, Clip, Aired on 10/02/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-pete-davidson-on-the-met-gala/607685697"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="607685697"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Pete Davidson on the Met Gala</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/02/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="24" aria-label="Saturday Night Live, Billionaire Star Trek, Clip, Aired on 10/02/21" tabindex="-1" href="/saturday-night-live/video/billionaire-star-trek/607173628"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="607173628"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Billionaire Star Trek</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/02/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="25" aria-label="Saturday Night Live, Cars 4, Clip, Aired on 10/02/21" tabindex="-1" href="/saturday-night-live/video/cars-4/607685702"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="607685702"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Cars 4</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/02/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="26" aria-label="Saturday Night Live, School Board Meeting, Clip, Aired on 10/02/21" tabindex="-1" href="/saturday-night-live/video/school-board-meeting/607685796"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="607685796"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">School Board Meeting</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/02/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="27" aria-label="Saturday Night Live, Splitting the Check, Clip, Aired on 10/02/21" tabindex="-1" href="/saturday-night-live/video/splitting-the-check/607685700"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="607685700"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Splitting the Check</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/02/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="28" aria-label="Saturday Night Live, Weekend Update: NBA Vaccinations, Disney World Turns 50, Clip, Aired on 10/02/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-nba-vaccinations-disney-world-turns-50/606149901"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="606149901"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: NBA Vaccinations, Disney World Turns 50</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/02/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="29" aria-label="Saturday Night Live, Mail-in Testing Service, Clip, Aired on 10/02/21" tabindex="-1" href="/saturday-night-live/video/mail-in-testing-service/607173636"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="607173636"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Mail-in Testing Service</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/02/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="30" aria-label="Saturday Night Live, Weekend Update: A Black Woman Who’s Been Missing for Ten Years, Clip, Aired on 10/02/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-a-black-woman-whos-been-missing-for-ten-years/607173630"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="607173630"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: A Black Woman Who’s Been Missing for Ten Years</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/02/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="31" aria-label="Saturday Night Live, Weekend Update Pays Tribute to Norm Macdonald, Clip, Aired on 10/02/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-pays-tribute-to-norm-macdonald/606661926"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="606661926"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update Pays Tribute to Norm Macdonald</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/02/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="32" aria-label="Saturday Night Live, Women’s Talk Show, Clip, Aired on 10/02/21" tabindex="-1" href="/saturday-night-live/video/womens-talk-show/607173627"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="607173627"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Women’s Talk Show</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/02/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="33" aria-label="Saturday Night Live, Funeral Song, Clip, Aired on 10/02/21" tabindex="-1" href="/saturday-night-live/video/funeral-song/606149900"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="606149900"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Funeral Song</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/02/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="34" aria-label="Saturday Night Live, NFL on Fox, Clip, Aired on 10/02/21" tabindex="-1" href="/saturday-night-live/video/nfl-on-fox/606661927"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="606661927"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">NFL on Fox</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/02/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="35" aria-label="Saturday Night Live, Kacey Musgraves: justified (Live), Clip, Aired on 10/02/21" tabindex="-1" href="/saturday-night-live/video/kacey-musgraves-justified-live/607685696"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="607685696"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Kacey Musgraves: justified (Live)</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/02/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="36" aria-label="Saturday Night Live, Kacey Musgraves: camera roll (Live), Clip, Aired on 10/02/21" tabindex="-1" href="/saturday-night-live/video/kacey-musgraves-camera-roll-live/606661928"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="606661928"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Kacey Musgraves: camera roll (Live)</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/02/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="37" aria-label="Saturday Night Live, Radiohead: The National Anthem (Live), Clip, Aired on 10/01/21" tabindex="-1" href="/saturday-night-live/video/radiohead-the-national-anthem-live/492997945"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="492997945"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Radiohead: The National Anthem (Live)</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>10/01/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="38" aria-label="Saturday Night Live, Owen Wilson Hosts the SNL Season Premiere!, Clip, Aired on 09/30/21" tabindex="-1" href="/saturday-night-live/video/owen-wilson-hosts-the-snl-season-premiere/430533637"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="430533637"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Owen Wilson Hosts the SNL Season Premiere!</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>09/30/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="39" aria-label="Saturday Night Live, Celebrate Fall with SNL, Clip, Aired on 09/24/21" tabindex="-1" href="/saturday-night-live/video/celebrate-fall-with-snl/847365867"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="847365867"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Celebrate Fall with SNL</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>09/24/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="40" aria-label="Saturday Night Live, SNL Returns October 2, Clip, Aired on 09/09/21" tabindex="-1" href="/saturday-night-live/video/snl-returns-october-2/435269968"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="435269968"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">SNL Returns October 2</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>09/09/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="41" aria-label="Saturday Night Live, End of Summer Barbecue with SNL, Clip, Aired on 09/09/21" tabindex="-1" href="/saturday-night-live/video/end-of-summer-barbecue-with-snl/460357517"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="460357517"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">End of Summer Barbecue with SNL</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>09/09/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="42" aria-label="Saturday Night Live, Rush with SNL, Clip, Aired on 09/02/21" tabindex="-1" href="/saturday-night-live/video/rush-with-snl/105189671"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="105189671"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Rush with SNL</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>09/02/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="43" aria-label="Saturday Night Live, Go to the Movies with SNL, Clip, Aired on 08/31/21" tabindex="-1" href="/saturday-night-live/video/go-to-the-movies-with-snl/879237688"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="879237688"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Go to the Movies with SNL</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>08/31/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="44" aria-label="Saturday Night Live, Back to School with SNL, Clip, Aired on 08/25/21" tabindex="-1" href="/saturday-night-live/video/back-to-school-with-snl/310405537"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="310405537"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Back to School with SNL</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>08/25/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="45" aria-label="Saturday Night Live, SNL Stories from the Show: Dave Chappelle, Clip, Aired on 08/24/21" tabindex="-1" href="/saturday-night-live/video/snl-stories-from-the-show-dave-chappelle/271493896"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="271493896"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">SNL Stories from the Show: Dave Chappelle</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>08/24/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="46" aria-label="Saturday Night Live, Back to Broadway with SNL, Clip, Aired on 08/19/21" tabindex="-1" href="/saturday-night-live/video/back-to-broadway-with-snl/832197957"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="832197957"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Back to Broadway with SNL</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>08/19/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="47" aria-label="Saturday Night Live, SNL Presents What&#x27;s Hot on TV, Clip, Aired on 08/17/21" tabindex="-1" href="/saturday-night-live/video/snl-presents-whats-hot-on-tv/881861516"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="881861516"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">SNL Presents What&#x27;s Hot on TV</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>08/17/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="48" aria-label="Saturday Night Live, Every Gilly Ever, Clip, Aired on 08/10/21" tabindex="-1" href="/saturday-night-live/video/every-gilly-ever/251077994"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="251077994"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Every Gilly Ever</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>08/10/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="49" aria-label="Saturday Night Live, Go to the Pool with SNL, Clip, Aired on 07/29/21" tabindex="-1" href="/saturday-night-live/video/go-to-the-pool-with-snl/4398117"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4398117"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Go to the Pool with SNL</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>07/29/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="50" aria-label="Saturday Night Live, SNL Presents Summer Vacation, Clip, Aired on 07/27/21" tabindex="-1" href="/saturday-night-live/video/snl-presents-summer-vacation/4398118"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4398118"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">SNL Presents Summer Vacation</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>07/27/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="51" aria-label="Saturday Night Live, SNL Presents Summer Olympics, Clip, Aired on 07/22/21" tabindex="-1" href="/saturday-night-live/video/snl-presents-summer-olympics/4397599"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4397599"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">SNL Presents Summer Olympics</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>07/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="52" aria-label="Saturday Night Live, Workout at Home with SNL, Clip, Aired on 07/20/21" tabindex="-1" href="/saturday-night-live/video/workout-at-home-with-snl/4397598"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4397598"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Workout at Home with SNL</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>07/20/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="53" aria-label="Saturday Night Live, Every Wayne’s World Ever: Part 3, Clip, Aired on 07/15/21" tabindex="-1" href="/saturday-night-live/video/every-waynes-world-ever-part-3/4393283"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4393283"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Every Wayne’s World Ever: Part 3</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>07/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="54" aria-label="Saturday Night Live, Every Wayne’s World Ever: Part 2, Clip, Aired on 07/14/21" tabindex="-1" href="/saturday-night-live/video/every-waynes-world-ever-part-2/4393280"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4393280"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Every Wayne’s World Ever: Part 2</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>07/14/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="55" aria-label="Saturday Night Live, Every Wayne’s World Ever: Part 1, Clip, Aired on 07/13/21" tabindex="-1" href="/saturday-night-live/video/every-waynes-world-ever-part-1/4393279"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4393279"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Every Wayne’s World Ever: Part 1</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>07/13/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="56" aria-label="Saturday Night Live, Weekend Update: Victoria Jackson on Amerika, Clip, Aired on 07/08/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-segment---victoria-jackson/n9547"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="53726f442648b7a77706e3829b0a910b"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Victoria Jackson on Amerika</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>07/08/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="57" aria-label="Saturday Night Live, Weekend Update: Victoria Jackson Reads a Christmas Poem, Clip, Aired on 07/08/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-victoria-jackson-reads-a-christmas-poem/4392506"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4392506"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Victoria Jackson Reads a Christmas Poem</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>07/08/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="58" aria-label="Saturday Night Live, Every Coffee Talk Ever: Part 2, Clip, Aired on 07/08/21" tabindex="-1" href="/saturday-night-live/video/every-coffee-talk-ever-part-2/4384419"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4384419"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Every Coffee Talk Ever: Part 2</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>07/08/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="59" aria-label="Saturday Night Live, Every Coffee Talk Ever: Part 1, Clip, Aired on 07/06/21" tabindex="-1" href="/saturday-night-live/video/every-coffee-talk-ever-part-1/4384417"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4384417"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Every Coffee Talk Ever: Part 1</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>07/06/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="60" aria-label="Saturday Night Live, SNL Presents Summer Vibes, Clip, Aired on 07/01/21" tabindex="-1" href="/saturday-night-live/video/snl-presents-summer-vibes/4385049"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4385049"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">SNL Presents Summer Vibes</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>07/01/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="61" aria-label="Saturday Night Live, Every What’s Wrong with This Picture Ever, Clip, Aired on 06/29/21" tabindex="-1" href="/saturday-night-live/video/every-whats-wrong-with-this-picture-ever/4384412"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4384412"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Every What’s Wrong with This Picture Ever</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>06/29/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="62" aria-label="Saturday Night Live, Every Close Encounter Ever: Part 2, Clip, Aired on 06/25/21" tabindex="-1" href="/saturday-night-live/video/every-close-encounter-ever-part-2/4384411"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4384411"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Every Close Encounter Ever: Part 2</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>06/25/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="63" aria-label="Saturday Night Live, The Making of SNL During COVID: Stories From the Show, Clip, Aired on 06/24/21" tabindex="-1" href="/saturday-night-live/video/the-making-of-snl-during-covid-stories-from-the-show/4384064"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4384064"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">The Making of SNL During COVID: Stories From the Show</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>06/24/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="64" aria-label="Saturday Night Live, Season 46 Finale Cold Open, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/season-46-finale-cold-open/4367115"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367115"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Season 46 Finale Cold Open</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="65" aria-label="Saturday Night Live, Anya Taylor-Joy Monologue, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/anya-taylorjoy-monologue/4367116"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367116"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Anya Taylor-Joy Monologue</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="66" aria-label="Saturday Night Live, Weekend Update: Colin Jost and Michael Che Swap Jokes for Season 46 Finale, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-colin-jost-and-michael-che-swap-jokes-for-season-46-finale/4367127"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367127"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Colin Jost and Michael Che Swap Jokes for Season 46 Finale</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="67" aria-label="Saturday Night Live, Weekend Update: Pete Davidson on Mental Health and the COVID-19  Pandemic, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-pete-davidson-on-mental-health-and-the-covid19-pandemic/4367125"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367125"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Pete Davidson on Mental Health and the COVID-19  Pandemic</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="68" aria-label="Saturday Night Live, Pride Month Song, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/pride-month-song/4367130"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367130"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Pride Month Song</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="69" aria-label="Saturday Night Live, College Panel, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/college-panel/4367119"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367119"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">College Panel</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="70" aria-label="Saturday Night Live, Hollywood Squares, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/hollywood-squares/4367120"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367120"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Hollywood Squares</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="71" aria-label="Saturday Night Live, Making Man, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/making-man/4367117"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367117"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Making Man</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="72" aria-label="Saturday Night Live, Lingerie Store, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/lingerie-store/4367133"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367133"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Lingerie Store</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="73" aria-label="Saturday Night Live, Celtic Woman, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/celtic-woman/4367122"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367122"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Celtic Woman</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="74" aria-label="Saturday Night Live, Weekend Update:  Republicans to Block January 6 Investigation, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-republicans-to-block-january-6-investigation/4367124"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367124"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update:  Republicans to Block January 6 Investigation</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="75" aria-label="Saturday Night Live, Picture with Dad, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/picture-with-dad/4367121"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367121"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Picture with Dad</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="76" aria-label="Saturday Night Live, Weekend Update: Jeanine Pirro on the Mexico–United States border, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-jeanine-pirro-on-the-mexicounited-states-border/4367128"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367128"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Jeanine Pirro on the Mexico–United States border</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="77" aria-label="Saturday Night Live, Weekend Update: Marilyn Manson Sued, Helen Keller Doll, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-marilyn-manson-sued-helen-keller-doll/4367126"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367126"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Marilyn Manson Sued, Helen Keller Doll</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="78" aria-label="Saturday Night Live, AMC Theatres Commercial, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/amc-theatres-commercial/4367129"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367129"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">AMC Theatres Commercial</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="79" aria-label="Saturday Night Live, Backstage Pitch, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/backstage-pitch/4367118"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4367118"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Backstage Pitch</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="80" aria-label="Saturday Night Live, Every Close Encounter Ever: Part 1, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/every-close-encounter-ever-part-1/4383676"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4383676"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Every Close Encounter Ever: Part 1</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="81" aria-label="Saturday Night Live, Every Movie Auditions Ever: Part 2, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/every-movie-auditions-ever-part-2/4405417"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4405417"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Every Movie Auditions Ever: Part 2</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="82" aria-label="Saturday Night Live, Every Movie Auditions Ever: Part 1, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/every-movie-auditions-ever-part-1/4405416"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4405416"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Every Movie Auditions Ever: Part 1</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="83" aria-label="Saturday Night Live, Star Quality, Clip, Aired on 05/22/21" tabindex="-1" href="/saturday-night-live/video/star-quality/4368580"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4368580"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Star Quality</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/22/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="84" aria-label="Saturday Night Live, Anya Taylor-Joy and Lil Nas X Agree This Finale Is the Best SNL Show of the Season, Clip, Aired on 05/20/21" tabindex="-1" href="/saturday-night-live/video/anya-taylorjoy-and-lil-nas-x-agree-this-finale-is-the-best-snl-show-of-the-season/4365816"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4365816"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Anya Taylor-Joy and Lil Nas X Agree This Finale Is the Best SNL Show of the Season</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/20/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="85" aria-label="Saturday Night Live, No More Masks Cold Open, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/no-more-masks-cold-open/4362992"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4362992"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">No More Masks Cold Open</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="86" aria-label="Saturday Night Live, Keegan-Michael Key Monologue, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/keeganmichael-key-monologue/4362993"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4362993"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Keegan-Michael Key Monologue</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="87" aria-label="Saturday Night Live, Weekend Update: CDC Lifts Mask Mandate, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-cdc-lifts-mask-mandate/4363000"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4363000"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: CDC Lifts Mask Mandate</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="88" aria-label="Saturday Night Live, Weekend Update: Liz Cheney on the Republican Party, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-liz-cheney-on-the-republican-party/4363003"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4363003"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Liz Cheney on the Republican Party</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="89" aria-label="Saturday Night Live, The Muppet Show, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/the-muppet-show/4362996"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4362996"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">The Muppet Show</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="90" aria-label="Saturday Night Live, Weekend Update: Tom Cruise Returns Golden Globes &amp; Ohio State Massage Therapist, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-tom-cruise-returns-golden-globes-ohio-state-massage-therapist/4363001"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4363001"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Tom Cruise Returns Golden Globes &amp; Ohio State Massage Therapist</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="91" aria-label="Saturday Night Live, Weekend Update: Andrew Dismukes on Great-Grandmas, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-andrew-dismukes-on-greatgrandmas/4363002"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4363002"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Andrew Dismukes on Great-Grandmas</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="92" aria-label="Saturday Night Live, High School Graduation, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/high-school-graduation/4362994"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4362994"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">High School Graduation</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="93" aria-label="Saturday Night Live, Gemma &amp; DJ Balls, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/gemma-dj-balls/4362998"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4362998"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Gemma &amp; DJ Balls</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="94" aria-label="Saturday Night Live, Prom Show, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/prom-show/4363006"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4363006"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Prom Show</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="95" aria-label="Saturday Night Live, Sending Drinks, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/sending-drinks/4363005"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4363005"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Sending Drinks</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="96" aria-label="Saturday Night Live, The Last Dance: Extended Scene, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/the-last-dance-extended-scene/4362995"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4362995"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">The Last Dance: Extended Scene</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="97" aria-label="Saturday Night Live, Weekend Update: Bob Baffert on Medina Spirit’s Failed Drug Test, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/weekend-update-bob-baffert-on-medina-spirits-failed-drug-test/4363004"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4363004"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Weekend Update: Bob Baffert on Medina Spirit’s Failed Drug Test</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="98" aria-label="Saturday Night Live, Rap Diss, Clip, Aired on 05/15/21" tabindex="-1" href="/saturday-night-live/video/rap-diss/4362997"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4362997"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Rap Diss</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/15/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li><li class="tile tile--clip tile--zoomable"><a class="tile" data-index="99" aria-label="Saturday Night Live, Keegan-Michael Key Promises the Best SNL in 46 Years, Clip, Aired on 05/13/21" tabindex="-1" href="/saturday-night-live/video/keeganmichael-key-promises-the-best-snl-in-46-years/4362032"><article class="tile__content"><div class="tile__thumbnail vilynx_enabled" data-vilynx-id="4362032"></div><div class="tile__meta tile__meta--branded"><div class="tile__meta__text"><div class="tile__title">Keegan-Michael Key Promises the Best SNL in 46 Years</div><div class="tile__description"><span class="tile__meta__badge">CLIP</span> <span>05/13/21</span></div></div><div class="tile__brand-logo"><div class="brand-logo brand-logo--align-right"><img alt="NBC" sizes="100vw" srcSet="https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=340&amp;imdensity=1 340w, https://img.nbc.com/sites/nbcunbc/files/images/2019/3/13/NBC-Logo-White-312x300.png?impolicy=nbc_com&amp;imwidth=170&amp;imdensity=1 170w" class="brand-logo__image"/></div></div></div></article></a></li></ul></div><button type="button" class="shelf__arrow shelf__arrow--right" disabled="" aria-hidden="true"></button></div></section></div></div></section><section class="links-selectable-group"><div class="links-selectable-group__container"><div class="links-selectable-group__inner"><div class="filter-select"><button type="button" class="filter-select__inner" aria-haspopup="listbox" aria-labelledby="undefined undefined" aria-label="Season 47" aria-expanded="false"><span class="filter-select__selected">Season 47</span></button><ul class="filter-select__dropdown" role="listbox" tabindex="-1" aria-activedescendant="undefined-Season 47"><li class="filter-select__item" role="option" aria-selected="true" id="undefined-Season 47" tabindex="0"><span class="filter-select__link">Season 47</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 46" tabindex="0"><span class="filter-select__link">Season 46</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 45" tabindex="0"><span class="filter-select__link">Season 45</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 44" tabindex="0"><span class="filter-select__link">Season 44</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 43" tabindex="0"><span class="filter-select__link">Season 43</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 42" tabindex="0"><span class="filter-select__link">Season 42</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 41" tabindex="0"><span class="filter-select__link">Season 41</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 40" tabindex="0"><span class="filter-select__link">Season 40</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 39" tabindex="0"><span class="filter-select__link">Season 39</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 38" tabindex="0"><span class="filter-select__link">Season 38</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 37" tabindex="0"><span class="filter-select__link">Season 37</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 36" tabindex="0"><span class="filter-select__link">Season 36</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 35" tabindex="0"><span class="filter-select__link">Season 35</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 34" tabindex="0"><span class="filter-select__link">Season 34</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 33" tabindex="0"><span class="filter-select__link">Season 33</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 32" tabindex="0"><span class="filter-select__link">Season 32</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 31" tabindex="0"><span class="filter-select__link">Season 31</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 30" tabindex="0"><span class="filter-select__link">Season 30</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 5" tabindex="0"><span class="filter-select__link">Season 5</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 4" tabindex="0"><span class="filter-select__link">Season 4</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 3" tabindex="0"><span class="filter-select__link">Season 3</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 2" tabindex="0"><span class="filter-select__link">Season 2</span></li><li class="filter-select__item" role="option" aria-selected="false" id="undefined-Season 1" tabindex="0"><span class="filter-select__link">Season 1</span></li></ul></div><div class="lazy-component lazy-component--loading"><div class="spinner spinner--absolute spinner--light" theme="light" style="top:50%"><span style="animation-delay:-1.2s;transform:rotate(0deg) translate(146%)"></span><span style="animation-delay:-1.1s;transform:rotate(30deg) translate(146%)"></span><span style="animation-delay:-1s;transform:rotate(60deg) translate(146%)"></span><span style="animation-delay:-0.9s;transform:rotate(90deg) translate(146%)"></span><span style="animation-delay:-0.8s;transform:rotate(120deg) translate(146%)"></span><span style="animation-delay:-0.7s;transform:rotate(150deg) translate(146%)"></span><span style="animation-delay:-0.6s;transform:rotate(180deg) translate(146%)"></span><span style="animation-delay:-0.5s;transform:rotate(210deg) translate(146%)"></span><span style="animation-delay:-0.4s;transform:rotate(240deg) translate(146%)"></span><span style="animation-delay:-0.3s;transform:rotate(270deg) translate(146%)"></span><span style="animation-delay:-0.2s;transform:rotate(300deg) translate(146%)"></span><span style="animation-delay:-0.1s;transform:rotate(330deg) translate(146%)"></span></div></div></div></div></section></div></div></div><footer class="footer " role="contentinfo"><div class="footer__container"><div class="footer__logo"><a class="footer__logo__link footer__logo__link--nbc" href="/">NBC.com</a></div><section class="footer__top"><div><div class="footer__left"><div class="social-icons"><h2 class="social-icons__title">Share the Moment<span class="social-icons__trademark">™</span></h2><ul class="social-icons__icons"><li><a rel="noreferrer noopener" target="_blank" class="social-icons__icon--wrapper" name="facebook" role="link" title="Facebook" href="https://www.facebook.com/nbc"><span class="social-icons__icon facebook"></span></a></li><li><a rel="noreferrer noopener" target="_blank" class="social-icons__icon--wrapper" name="twitter" role="link" title="Twitter" href="https://twitter.com/nbc"><span class="social-icons__icon twitter"></span></a></li><li><a rel="noreferrer noopener" target="_blank" class="social-icons__icon--wrapper" name="tumblr" role="link" title="Tumblr" href="https://nbctv.tumblr.com"><span class="social-icons__icon tumblr"></span></a></li><li><a rel="noreferrer noopener" target="_blank" class="social-icons__icon--wrapper" name="pinterest" role="link" title="Pinterest" href="https://pinterest.com/nbctv"><span class="social-icons__icon pinterest"></span></a></li><li><a rel="noreferrer noopener" target="_blank" class="social-icons__icon--wrapper" name="youtube" role="link" title="YouTube" href="https://www.youtube.com/nbc"><span class="social-icons__icon youtube"></span></a></li></ul></div></div><div class="footer__right"><div class="quick-links"><h2 class="quick-links__title">NBC Quick Links</h2><ul class="quick-links__list"><li><a href="/mvpd-picker" target="">Link TV Provider</a></li><li><a target="_blank" rel="noreferrer noopener" href="">FAQ</a></li><li><a href="/global/pages/casting" target="">Casting</a></li><li><a target="_blank" rel="noreferrer noopener" href="">Contact Us</a></li><li><a href="/global/pages/tv-ratings" target="">Parental Guidelines and TV Ratings</a></li><li><a href="/tickets/pages/tickets-and-nbc-studio-tour" target="">Tickets and NBC Studio Tour</a></li><li><a href="/schedule" target="">Local Schedule</a></li></ul></div></div></div></section><div class="footer__legal"><div class="corporate-links"><ul class="corporate-links__list"><li><a href="/general/pages/accessibility" target="">Accessibility</a></li><li><a target="" rel="noreferrer noopener" href="http://www.nbcuni.com/">Corporate Info</a></li><li><a target="" rel="noreferrer noopener" href="http://www.nbcunicareers.com/">Jobs</a></li><li><a target="" rel="noreferrer noopener" href="https://www.nbcuniversal.com/privacy?intake=NBC_Entertainment">Privacy Policy</a></li><li><a href="/general/pages/terms" target="">Terms of Service</a></li><li><a href="/general/pages/advertise" target="">Advertise</a></li><li><a target="" rel="noreferrer noopener" href="http://nbc.researchresults.com/?s=657">Viewer Panel</a></li><li><a target="" rel="noreferrer noopener" href="https://www.nbcuniversal.com/privacy/california-consumer-privacy-act?intake=NBC_Entertainment">CA Notice</a></li><li><a href="/general/pages/closed-captioning" target="">Closed Captioning</a></li><li><a target="" rel="noreferrer noopener" href="https://www.nbcuniversal.com/privacy/notrtoo?intake=NBC_Entertainment">Do Not Sell My Personal Information</a></li><li><a href="/general/pages/vppa" target="">Video Viewing Policy</a></li><li><a target="" rel="noreferrer noopener" href="https://www.peacocktv.com/?cid=20200101evergreenoneedi002&amp;utm_source=nbc&amp;utm_medium=oneapp_editorial_footer_footerlink&amp;utm_campaign=20200101evergreen&amp;utm_term=weblink&amp;utm_content=footerlink">Peacock</a></li></ul></div></div></div><div class="footer__base"><ul class="footer__base__list"><li>A Division of <strong>NBCUniversal</strong></li><li><a href="https://www.nbcuniversal.com/privacy/cookies#accordionheader2" target="_blank" rel="noopener noreferrer">Ad Choices</a></li><li>©<!-- -->2021<!-- --> NBCUniversal Media, LLC</li></ul></div></footer><div class="responsive-app__cookies"><div class="responsive-app__cookies__wrapper"><div class="responsive-app__cookies__inner"><div class="responsive-app__cookies__text">We and our partners use cookies on this site to improve our service, perform analytics, personalize advertising, measure advertising performance, and remember website preferences. By using the site, you consent to these cookies. For more information on cookies including how to manage your consent visit our<!-- --> <a target="_blank" href="https://www.nbcuniversal.com/privacy/cookies" rel="noopener noreferrer">cookie policy</a>.</div><button class="button" type="button"><span><i></i>Continue</span></button></div></div></div></main></div></div>
        <script>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</script>
        <div id="scripts" data-reactroot=""><script src="/generetic/scripts/ads.js"></script><script src="https://entitlement.auth.adobe.com/entitlement/v4/AccessEnabler.js"></script><script src="https://pdk.theplatform.com/5.8.7/pdk/tpPdkController.js"></script><script src="//assets.adobedtm.com/a2ef59fba8e9/9c7a708dbcb2/launch-678397df18e0.min.js" async=""></script><script src="https://cdn.cookielaw.org/consent/ea571e64-7f5b-48d8-8d41-f96b1ddd4838/otSDKStub.js" crossorigin="anonymous" type="text/javascript" charset="UTF-8" data-domain-script="ea571e64-7f5b-48d8-8d41-f96b1ddd4838" integrity="sha384-MBKHs93r8p+/FKCTzkPhNxbLTPNVCDEZC9KBNEN/gkg+JepD6JUJXYf7VQHn9qmj" async=""></script></div>
        <script async src=/generetic/generated/chunks/49.a89bfc9347d14ee84412.js></script>
<script async src=/generetic/generated/generetic.d5b2ea14d1f912c615fc.js></script>
<script async src=/generetic/generated/chunks/0.9a3cdf05c3fd4562d8cd.js></script>
<script async src=/generetic/generated/chunks/1.c2ae86ca7dbf30d7ee12.js></script>
<script async src=/generetic/generated/chunks/11.e5794a4e3d1f3652324a.js></script>
<script async src=/generetic/generated/chunks/2.7c5fcc55ad4712c4190c.js></script>
<script async src=/generetic/generated/chunks/45.615a1752edad80af5b2a.js></script>
      </body>
    </html>